summaryrefslogtreecommitdiffstats
path: root/x11/libsexy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-02 12:46:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-02 12:46:03 +0000
commit5d8f74148ddc88d96794a963f676c658959c37d9 (patch)
tree38182daa9b1e630727f5307dda82051311aba1e0 /x11/libsexy
parentb74c0698ee9952b113a032bb965a6248159c98ed (diff)
downloadaports-5d8f74148ddc88d96794a963f676c658959c37d9.tar.bz2
aports-5d8f74148ddc88d96794a963f676c658959c37d9.tar.xz
x11/libsexy: new aport
Doing naughty things to good widgets. http://chipx86.com/wiki/Libsexy
Diffstat (limited to 'x11/libsexy')
-rw-r--r--x11/libsexy/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11/libsexy/APKBUILD b/x11/libsexy/APKBUILD
new file mode 100644
index 00000000..64488a0a
--- /dev/null
+++ b/x11/libsexy/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsexy
+pkgver=0.1.11
+pkgrel=0
+pkgdesc="Doing naughty things to good widgets."
+url="http://chipx86.com/wiki/Libsexy"
+license="GPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="gtk+-dev libxml2-dev iso-codes"
+source="http://releases.chipx86.com/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/libsexy.a
+}
+
+md5sums="33c079a253270ec8bfb9508e4bb30754 libsexy-0.1.11.tar.gz"