summaryrefslogtreecommitdiffstats
path: root/x11/libxmu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-31 08:55:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-31 08:55:07 +0000
commit53666ff60d8cdb5f3ea712f582d31f5caba0e413 (patch)
tree976459794f850ba9a31c28a994386aaf614b5c11 /x11/libxmu
parent07a88a4dc20c3cf824dc1d4901824410387aa087 (diff)
downloadaports-53666ff60d8cdb5f3ea712f582d31f5caba0e413.tar.bz2
aports-53666ff60d8cdb5f3ea712f582d31f5caba0e413.tar.xz
x11/libxmu: new aport
X11 miscellaneous micro-utility library
Diffstat (limited to 'x11/libxmu')
-rw-r--r--x11/libxmu/APKBUILD28
-rw-r--r--x11/libxmu/nocxx.patch15
2 files changed, 43 insertions, 0 deletions
diff --git a/x11/libxmu/APKBUILD b/x11/libxmu/APKBUILD
new file mode 100644
index 00000000..67c4f2a0
--- /dev/null
+++ b/x11/libxmu/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxmu
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="X11 miscellaneous micro-utility library"
+url="http://xorg.freedesktop.org/"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="libxext libxt libx11 libsm uclibc"
+makedepends="pkgconfig libxext-dev libxt-dev libx11-dev libsm-dev"
+source="http://xorg.freedesktop.org/releases/individual/lib/libXmu-$pkgver.tar.bz2
+ nocxx.patch"
+depends_dev="xproto libx11-dev libxt-dev libxext-dev"
+
+build ()
+{
+ cd "$srcdir"/libXmu-$pkgver
+ patch -p1 < ../nocxx.patch configure || return 1
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 $srcdir/libXmu-$pkgver/COPYING \
+ $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="fb372a5f3ab42b5ba16d7af4d833a0cb libXmu-1.0.4.tar.bz2
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/x11/libxmu/nocxx.patch b/x11/libxmu/nocxx.patch
new file mode 100644
index 00000000..beb1ab90
--- /dev/null
+++ b/x11/libxmu/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc