summaryrefslogtreecommitdiffstats
path: root/x11/xfce4-battery-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-01 20:56:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-02 11:40:11 +0000
commita29975a138916dce5b8fc1ab673317c5c2509297 (patch)
tree7bb0c07dafe3574a5735fc06a1ec4601818b64ce /x11/xfce4-battery-plugin
parent05eec38aed3ecffa1cbd3fb9d50c62a77ba073d8 (diff)
downloadaports-a29975a138916dce5b8fc1ab673317c5c2509297.tar.bz2
aports-a29975a138916dce5b8fc1ab673317c5c2509297.tar.xz
x11/xfce4-battery-plugin: new aport
A battery monitor plugin for the Xfce panel http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin
Diffstat (limited to 'x11/xfce4-battery-plugin')
-rw-r--r--x11/xfce4-battery-plugin/APKBUILD26
-rw-r--r--x11/xfce4-battery-plugin/compile_x86_64.diff13
l---------x11/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall1
-rw-r--r--x11/xfce4-battery-plugin/xfce4-battery-plugin.post-install4
l---------x11/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade1
5 files changed, 45 insertions, 0 deletions
diff --git a/x11/xfce4-battery-plugin/APKBUILD b/x11/xfce4-battery-plugin/APKBUILD
new file mode 100644
index 00000000..d67d1715
--- /dev/null
+++ b/x11/xfce4-battery-plugin/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-battery-plugin
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="A battery monitor plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+license="GPL-2"
+makedepends="xfce4-panel-dev libxfcegui4-dev perl-xml-parser intltool"
+install="$pkname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2
+ compile_x86_64.diff"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/compile_x86_64.diff || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="d8a666d85bb3c1dd007b547de4dd7037 xfce4-battery-plugin-0.5.1.tar.bz2
+d9a927bca032e9b10a04046c154243a1 compile_x86_64.diff"
diff --git a/x11/xfce4-battery-plugin/compile_x86_64.diff b/x11/xfce4-battery-plugin/compile_x86_64.diff
new file mode 100644
index 00000000..102db1d9
--- /dev/null
+++ b/x11/xfce4-battery-plugin/compile_x86_64.diff
@@ -0,0 +1,13 @@
+--- xfce4-battery-plugin-0.5.0/panel-plugin/libapm.h.orig 2008-03-18 20:10:58.000000000 +0100
++++ xfce4-battery-plugin-0.5.0/panel-plugin/libapm.h 2008-03-18 20:14:45.000000000 +0100
+@@ -17,8 +17,8 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#include <linux/apm_bios.h>
+ #include <sys/types.h>
++#include <linux/apm_bios.h>
+
+ #define APM_PROC "/proc/apm"
+ #define APM_DEVICE "/dev/apm_bios"
+
diff --git a/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall b/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall
new file mode 120000
index 00000000..ffd189d1
--- /dev/null
+++ b/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall
@@ -0,0 +1 @@
+xfce4-battery-plugin.post-install \ No newline at end of file
diff --git a/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-install b/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-install
new file mode 100644
index 00000000..c523d78d
--- /dev/null
+++ b/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
diff --git a/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade b/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade
new file mode 120000
index 00000000..ffd189d1
--- /dev/null
+++ b/x11/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade
@@ -0,0 +1 @@
+xfce4-battery-plugin.post-install \ No newline at end of file