summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-12 22:25:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-12 22:25:42 +0000
commit0464a3ff8a0b295db39de0fb7e5806941367e0d1 (patch)
tree8f57eb4ce5debf162ffd64602b49de7b8dc0ffbf /x11
parent8efc7f4472cc1c7f803e9666f58ca6184f5b2457 (diff)
downloadaports-0464a3ff8a0b295db39de0fb7e5806941367e0d1.tar.bz2
aports-0464a3ff8a0b295db39de0fb7e5806941367e0d1.tar.xz
x11/libxkbfile: new aport
X11 keyboard file manipulation library
Diffstat (limited to 'x11')
-rw-r--r--x11/libxkbfile/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11/libxkbfile/APKBUILD b/x11/libxkbfile/APKBUILD
new file mode 100644
index 00000000..fdc45072
--- /dev/null
+++ b/x11/libxkbfile/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxkbfile
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="X11 keyboard file manipulation library"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends="libX11 uclibc"
+makedepends="pkgconfig libX11-dev"
+subpackages="$pkgname-dev"
+source="http://xorg.freedesktop.org/releases/individual/lib/$pkgname-$pkgver.tar.bz2"
+
+depends_dev="libX11-dev kbproto"
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 "$srcdir"/$pkgname-$pkgver/COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="0726a845fe5a56551de2718c9f6b0e35 libxkbfile-1.0.5.tar.bz2"