summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-13 22:25:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-13 23:21:19 +0000
commitfca8b6f4760a6a39b7ac8360e0068d238650b402 (patch)
tree7407638901ba93466b4898bdd4cb8305b4d48f10 /x11
parent2848283fc59350bd19fe94f96a3a83c0bd782aa7 (diff)
downloadaports-fca8b6f4760a6a39b7ac8360e0068d238650b402.tar.bz2
aports-fca8b6f4760a6a39b7ac8360e0068d238650b402.tar.xz
x11/xkeyboard-config: new aport
X keyboard configuration files http://www.freedesktop.org/wiki/Software/XKeyboardConfig
Diffstat (limited to 'x11')
-rw-r--r--x11/xkeyboard-config/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/xkeyboard-config/APKBUILD b/x11/xkeyboard-config/APKBUILD
new file mode 100644
index 00000000..07591c67
--- /dev/null
+++ b/x11/xkeyboard-config/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xkeyboard-config
+pkgver=1.5
+pkgrel=0
+pkgdesc="X keyboard configuration files"
+url="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+license="custom"
+depends="uclibc"
+makedepends="xkbcomp intltool"
+source="http://xlibs.freedesktop.org/xkbdesc/$pkgname-$pkgver.tar.bz2"
+
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --with-xkb-base=/usr/share/X11/xkb \
+ --with-xkb-rules-symlink=xorg \
+ --enable-compat-rules=yes || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/share/X11/xkb/compiled || return 1
+ install -m755 -d "$pkgdir"/var/lib/xkb
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="43c74312d303863b1b929554fa9ed9b3 xkeyboard-config-1.5.tar.bz2"