summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-16 20:08:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-16 20:08:04 +0000
commita7b5bf31b4f744e3cd1222104da620b4b62e103d (patch)
treeaf79c6c0258f80e68dd214e39c347cb6bd165886 /x11
parent4769c59c759e0c6c870e06f46d5a0f09b13c0646 (diff)
downloadaports-a7b5bf31b4f744e3cd1222104da620b4b62e103d.tar.bz2
aports-a7b5bf31b4f744e3cd1222104da620b4b62e103d.tar.xz
x11/rarian: new aport
Documentation meta-data library, designed as a replacement for Scrollkeeper http://rarian.freedesktop.org/
Diffstat (limited to 'x11')
-rw-r--r--x11/rarian/APKBUILD28
-rw-r--r--x11/rarian/user-segfault.patch14
2 files changed, 42 insertions, 0 deletions
diff --git a/x11/rarian/APKBUILD b/x11/rarian/APKBUILD
new file mode 100644
index 00000000..bf3caf14
--- /dev/null
+++ b/x11/rarian/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=rarian
+pkgver=0.8.1
+pkgrel=0
+pkgdesc="Documentation meta-data library, designed as a replacement for Scrollkeeper."
+url="http://rarian.freedesktop.org/"
+license="GPL"
+subpackages="$pkgname-dev"
+depends=
+makedepends="libxslt-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/0.8/$pkgname-$pkgver.tar.bz2
+ user-segfault.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p0 -i "$srcdir"/user-segfault.patch || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-scrollkeeper-compat \
+ --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="75091185e13da67a0ff4279de1757b94 rarian-0.8.1.tar.bz2
+457e9827197009cfa360911fe49a5ad7 user-segfault.patch"
diff --git a/x11/rarian/user-segfault.patch b/x11/rarian/user-segfault.patch
new file mode 100644
index 00000000..3311cecd
--- /dev/null
+++ b/x11/rarian/user-segfault.patch
@@ -0,0 +1,14 @@
+--- util/rarian-sk-get-cl.cpp~ 2008-07-28 19:23:28.000000000 +0200
++++ util/rarian-sk-get-cl.cpp 2008-07-28 19:23:28.000000000 +0200
+@@ -160,6 +160,11 @@
+ {
+ char *filename = NULL;
+ char *user = getenv ("USERNAME");
++
++ if (user == NULL) {
++ user = getenv ("USER");
++ }
++
+ char *basepath = NULL;
+ int i=0;
+ int last = 0;