summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-19 21:51:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-19 21:54:02 +0000
commitfe9b94909ef4f2c866ec66c733519a59b2f439b2 (patch)
tree95766316323f42ec1e27da1087e0d7876db21ce2 /x11
parentaa9f03189194b5b8d35efbf96c0db16d1708488e (diff)
downloadaports-fe9b94909ef4f2c866ec66c733519a59b2f439b2.tar.bz2
aports-fe9b94909ef4f2c866ec66c733519a59b2f439b2.tar.xz
x11/gtk-vnc: new aport
A VNC viewer widget for GTK http://live.gnome.org/gtk-vnc
Diffstat (limited to 'x11')
-rw-r--r--x11/gtk-vnc/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11/gtk-vnc/APKBUILD b/x11/gtk-vnc/APKBUILD
new file mode 100644
index 00000000..353b1205
--- /dev/null
+++ b/x11/gtk-vnc/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gtk-vnc
+pkgver=0.3.8
+pkgrel=0
+pkgdesc="A VNC viewer widget for GTK"
+url="http://live.gnome.org/gtk-vnc"
+license="LGPL"
+subpackages="$pkgname-dev"
+makedepends="gnutls-dev gtk+-dev libiconv-dev gettext-dev intltool expat-dev
+ libgcrypt-dev libgpg-error-dev"
+depends_dev="gtk+-dev gnutls-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/0.3/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --without-python \
+ --without-examples \
+ --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="7c7b07a868568206acd3f6e9e4d18ba1 gtk-vnc-0.3.8.tar.bz2"