summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/hypermail/APKBUILD13
-rw-r--r--testing/hypermail/mdir2mbox.lua (renamed from unstable/hypermail/mdir2mbox.lua)0
-rw-r--r--unstable/hypermail/APKBUILD36
3 files changed, 8 insertions, 41 deletions
diff --git a/testing/hypermail/APKBUILD b/testing/hypermail/APKBUILD
index 06ddf011..6e4f4123 100644
--- a/testing/hypermail/APKBUILD
+++ b/testing/hypermail/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=hypermail
-pkgver=2.1.8
+pkgver=2.2.0
pkgrel=0
pkgdesc="Mail Archiver"
-url="http://www.hypermail.org"
+url="http://www.hypermail-project.org"
license="GPL"
-depends="uclibc pcre"
+depends="uclibc pcre lua"
makedepends="pcre-dev bison"
install=
subpackages=""
-source="http://www.hypermail.org/dist/$pkgname-$pkgver.tar.gz"
+source="http://www.hypermail-project.org/$pkgname-$pkgver.tar.gz
+ mdir2mbox.lua"
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -27,7 +28,9 @@ build() {
install -m755 -D archive/rdmsg "$pkgdir"/usr/bin/rdmsg
install -m755 -D archive/msg2archive "$pkgdir"/usr/bin/msgarchive
install -m755 -D src/hypermail "$pkgdir"/usr/bin/hypermail
+ install -m755 -D "$srcdir"/mdir2mbox.lua "$pkgdir"/usr/bin/mdir2mbox.lua
}
-md5sums="bacd95589f2f3ca426631461fd9237dd hypermail-2.1.8.tar.gz"
+md5sums="a064e36780ee41409c8c973f9c69927f hypermail-2.2.0.tar.gz
+079b00d4ea667a0efd6fd370b1a4d5d8 mdir2mbox.lua"
diff --git a/unstable/hypermail/mdir2mbox.lua b/testing/hypermail/mdir2mbox.lua
index dd883e02..dd883e02 100644
--- a/unstable/hypermail/mdir2mbox.lua
+++ b/testing/hypermail/mdir2mbox.lua
diff --git a/unstable/hypermail/APKBUILD b/unstable/hypermail/APKBUILD
deleted file mode 100644
index 6e4f4123..00000000
--- a/unstable/hypermail/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-pkgname=hypermail
-pkgver=2.2.0
-pkgrel=0
-pkgdesc="Mail Archiver"
-url="http://www.hypermail-project.org"
-license="GPL"
-depends="uclibc pcre lua"
-makedepends="pcre-dev bison"
-install=
-subpackages=""
-source="http://www.hypermail-project.org/$pkgname-$pkgver.tar.gz
- mdir2mbox.lua"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --with-httpddir=/var/www \
- --with-cgidir=/var/www/cgi-bin
- make || return 1
- #does not understand DESTDIR so going to install ourselves
- #make DESTDIR="$pkgdir" install
-
- install -m755 -D archive/rdmsg "$pkgdir"/usr/bin/rdmsg
- install -m755 -D archive/msg2archive "$pkgdir"/usr/bin/msgarchive
- install -m755 -D src/hypermail "$pkgdir"/usr/bin/hypermail
- install -m755 -D "$srcdir"/mdir2mbox.lua "$pkgdir"/usr/bin/mdir2mbox.lua
-
-}
-
-md5sums="a064e36780ee41409c8c973f9c69927f hypermail-2.2.0.tar.gz
-079b00d4ea667a0efd6fd370b1a4d5d8 mdir2mbox.lua"