summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/php/APKBUILD6
-rw-r--r--main/php/zend_execute_API.c.patch10
2 files changed, 14 insertions, 2 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index 34a5c779..1b72cc30 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php
pkgver=5.3.2
_suhosinver=${pkgver}-0.9.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
license="PHP-3"
@@ -63,6 +63,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-cli
source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2
http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz
+ zend_execute_API.c.patch
"
_extdir="/usr/lib/php/20090626"
@@ -241,4 +242,5 @@ dev() {
}
md5sums="46f500816125202c48a458d0133254a4 php-5.3.2.tar.bz2
-4647b05330862d6a1fc4469245cc6ade suhosin-patch-5.3.2-0.9.9.1.patch.gz"
+4647b05330862d6a1fc4469245cc6ade suhosin-patch-5.3.2-0.9.9.1.patch.gz
+55f9d24316a57e0c0f6b4b84791a1a17 zend_execute_API.c.patch"
diff --git a/main/php/zend_execute_API.c.patch b/main/php/zend_execute_API.c.patch
new file mode 100644
index 00000000..0976a7b3
--- /dev/null
+++ b/main/php/zend_execute_API.c.patch
@@ -0,0 +1,10 @@
+--- PHP_5_3/Zend/zend_execute_API.c 2009/12/18 18:41:53 292294
++++ PHP_5_3/Zend/zend_execute_API.c 2009/12/18 19:12:11 292295
+@@ -838,6 +838,7 @@
+ zval *param;
+
+ if (EX(function_state).function->type == ZEND_INTERNAL_FUNCTION
++ && (EX(function_state).function->common.fn_flags & ZEND_ACC_CALL_VIA_HANDLER) == 0
+ && !ARG_SHOULD_BE_SENT_BY_REF(EX(function_state).function, i + 1)
+ && PZVAL_IS_REF(*fci->params[i])) {
+ SEPARATE_ZVAL(fci->params[i]);