summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/sems/0001-makefile-fail-on-errors.patch170
-rw-r--r--testing/sems/0002-include-headers.patch116
-rw-r--r--testing/sems/0003-cc-and-cflags.patch45
-rw-r--r--testing/sems/APKBUILD61
4 files changed, 0 insertions, 392 deletions
diff --git a/testing/sems/0001-makefile-fail-on-errors.patch b/testing/sems/0001-makefile-fail-on-errors.patch
deleted file mode 100644
index 9dcbb230..00000000
--- a/testing/sems/0001-makefile-fail-on-errors.patch
+++ /dev/null
@@ -1,170 +0,0 @@
-From 7773c850b91d5c78679606065402caac29219dd8 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 18 Dec 2009 08:57:27 +0000
-Subject: [PATCH 1/2] makefile fail on errors
-
----
- Makefile | 8 ++++----
- apps/Makefile | 12 ++++++------
- core/Makefile | 2 +-
- core/plug-in/Makefile | 14 +++++++-------
- core/plug-in/Makefile.app_module | 4 ++--
- 5 files changed, 20 insertions(+), 20 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 7dd01de..c210761 100644
---- a/Makefile
-+++ b/Makefile
-@@ -28,21 +28,21 @@ clean:
-
- .PHONY: modules
- modules:
-- -@for r in $(modules) "" ; do \
-+ @for r in $(modules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- $(MAKE) -C $$r all; \
-+ $(MAKE) -C $$r all || exit 1; \
- fi ; \
- done
-
- .PHONY: install
- install:
-- -@for r in $(imodules) "" ; do \
-+ @for r in $(imodules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- $(MAKE) -C $$r install; \
-+ $(MAKE) -C $$r install || exit 1; \
- fi ; \
- done
- -@if [ -d ser-0.9.6-sems ]; then \
-diff --git a/apps/Makefile b/apps/Makefile
-index 23c6437..57df618 100644
---- a/apps/Makefile
-+++ b/apps/Makefile
-@@ -30,11 +30,11 @@ clean:
-
- .PHONY: modules
- modules:
-- -@for r in $(modules) "" ; do \
-+ @for r in $(modules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- COREPATH=../$(COREPATH) $(MAKE) -C $$r all; \
-+ COREPATH=../$(COREPATH) $(MAKE) -C $$r all || exit 1; \
- fi ; \
- done
-
-@@ -43,20 +43,20 @@ install: install-bin install-cfg
-
- .PHONY: install-bin
- install-bin:
-- -@for r in $(modules) "" ; do \
-+ @for r in $(modules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- COREPATH=../$(COREPATH) $(MAKE) -C $$r install; \
-+ COREPATH=../$(COREPATH) $(MAKE) -C $$r install || exit 1; \
- fi ; \
- done
-
- .PHONY: install-cfg
- install-cfg: $(DESTDIR)$(cfg-target)
-- -@for r in $(modules) "" ; do \
-+ @for r in $(modules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg; \
-+ COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg || exit 1; \
- fi ; \
- done
-diff --git a/core/Makefile b/core/Makefile
-index e3734d5..e1fe274 100644
---- a/core/Makefile
-+++ b/core/Makefile
-@@ -11,7 +11,7 @@ AUDIO_FILES=$(notdir $(wildcard wav/*.wav))
-
- .PHONY: all
- all: ../Makefile.defs
-- -@$(MAKE) deps && \
-+ @$(MAKE) deps && \
- $(MAKE) $(NAME) && \
- $(MAKE) modules
-
-diff --git a/core/plug-in/Makefile b/core/plug-in/Makefile
-index e7d988c..cc38e2f 100644
---- a/core/plug-in/Makefile
-+++ b/core/plug-in/Makefile
-@@ -1,6 +1,6 @@
- include ../../Makefile.defs
-
--exclude_modules ?= g722
-+exclude_modules ?= g722 speex
- #echo
-
- modules = $(filter-out $(subst ;, ,$(exclude_modules)) \
-@@ -25,30 +25,30 @@ clean:
-
- .PHONY: modules
- modules:
-- -@for r in $(modules) "" ; do \
-+ @for r in $(modules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- $(MAKE) -C $$r all; \
-+ $(MAKE) -C $$r all || exit 1; \
- fi ; \
- done
-
- .PHONY: install
- install:
-- -@for r in $(modules) "" ; do \
-+ @for r in $(modules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- $(MAKE) -C $$r install; \
-+ $(MAKE) -C $$r install || exit 1; \
- fi ; \
- done
-
- .PHONY: install-cfg
- install-cfg: $(DESTDIR)$(cfg-target)
-- -@for r in $(modules) "" ; do \
-+ @for r in $(modules) "" ; do \
- if [ -n "$$r" ]; then \
- echo "" ; \
- echo "" ; \
-- COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg; \
-+ COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg || exit 1; \
- fi ; \
- done
-diff --git a/core/plug-in/Makefile.app_module b/core/plug-in/Makefile.app_module
-index 8b7acaa..a6e1ef2 100644
---- a/core/plug-in/Makefile.app_module
-+++ b/core/plug-in/Makefile.app_module
-@@ -27,12 +27,12 @@ depends = $(srcs:.cpp=.d)
-
- .PHONY: all
- all: $(extra_target)
-- -@$(MAKE) deps && \
-+ @$(MAKE) deps && \
- $(MAKE) $(lib_full_name)
-
- .PHONY: module_package
- module_package: $(extra_target)
-- -@$(MAKE) deps && \
-+ @$(MAKE) deps && \
- $(MAKE) $(lib_name)
-
-
---
-1.6.5.6
-
diff --git a/testing/sems/0002-include-headers.patch b/testing/sems/0002-include-headers.patch
deleted file mode 100644
index 5e9a2477..00000000
--- a/testing/sems/0002-include-headers.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-From 43faa45d0455c5bb53a0f992ffc7bdf92c94c945 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 18 Dec 2009 08:58:18 +0000
-Subject: [PATCH 2/2] include headers
-
----
- apps/annrecorder/AnnRecorder.cpp | 2 ++
- apps/callback/CallBack.cpp | 1 +
- apps/diameter_client/ServerConnection.cpp | 1 +
- apps/diameter_client/ServerConnection.h | 1 +
- core/AmMediaProcessor.cpp | 1 +
- core/AmRtpReceiver.cpp | 1 +
- core/plug-in/sipctrl/udp_trsp.cpp | 1 +
- core/plug-in/stats/query_stats.cxx | 1 +
- 8 files changed, 9 insertions(+), 0 deletions(-)
-
-diff --git a/apps/annrecorder/AnnRecorder.cpp b/apps/annrecorder/AnnRecorder.cpp
-index b32cd58..7ba9639 100644
---- a/apps/annrecorder/AnnRecorder.cpp
-+++ b/apps/annrecorder/AnnRecorder.cpp
-@@ -25,6 +25,8 @@
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
-+#include <unistd.h>
-+
- #include "AnnRecorder.h"
- #include "AmConfig.h"
- #include "AmUtils.h"
-diff --git a/apps/callback/CallBack.cpp b/apps/callback/CallBack.cpp
-index 360e698..6019705 100644
---- a/apps/callback/CallBack.cpp
-+++ b/apps/callback/CallBack.cpp
-@@ -32,6 +32,7 @@
- #include "AmPlugIn.h"
-
- #include <stdlib.h>
-+#include <unistd.h>
-
- EXPORT_SESSION_FACTORY(CallBackFactory,MOD_NAME);
- string CallBackFactory::gw_user;
-diff --git a/apps/diameter_client/ServerConnection.cpp b/apps/diameter_client/ServerConnection.cpp
-index 4157304..3e2a14f 100644
---- a/apps/diameter_client/ServerConnection.cpp
-+++ b/apps/diameter_client/ServerConnection.cpp
-@@ -30,6 +30,7 @@
- #include "ampi/DiameterClientAPI.h"
- #include "diameter_client.h"
-
-+#include <unistd.h>
- #include <stdlib.h>
- #include <string.h>
- #include "log.h"
-diff --git a/apps/diameter_client/ServerConnection.h b/apps/diameter_client/ServerConnection.h
-index d797d15..0af146a 100644
---- a/apps/diameter_client/ServerConnection.h
-+++ b/apps/diameter_client/ServerConnection.h
-@@ -38,6 +38,7 @@
- #include <vector>
- #include <map>
- #include <utility>
-+#include <stdint.h>
- using std::string;
- using std::vector;
- using std::map;
-diff --git a/core/AmMediaProcessor.cpp b/core/AmMediaProcessor.cpp
-index 9650c91..0da86b0 100644
---- a/core/AmMediaProcessor.cpp
-+++ b/core/AmMediaProcessor.cpp
-@@ -29,6 +29,7 @@
- #include "AmSession.h"
- #include "AmRtpStream.h"
-
-+#include <unistd.h>
- #include <assert.h>
- #include <sys/time.h>
- #include <signal.h>
-diff --git a/core/AmRtpReceiver.cpp b/core/AmRtpReceiver.cpp
-index 5216b15..7f7fb4a 100644
---- a/core/AmRtpReceiver.cpp
-+++ b/core/AmRtpReceiver.cpp
-@@ -37,6 +37,7 @@
- #include <strings.h>
- #endif
-
-+#include <unistd.h>
- #include <sys/time.h>
- #include <sys/poll.h>
-
-diff --git a/core/plug-in/sipctrl/udp_trsp.cpp b/core/plug-in/sipctrl/udp_trsp.cpp
-index 49a8358..74f00ae 100644
---- a/core/plug-in/sipctrl/udp_trsp.cpp
-+++ b/core/plug-in/sipctrl/udp_trsp.cpp
-@@ -36,6 +36,7 @@
- #include <sys/param.h>
- #include <arpa/inet.h>
-
-+#include <unistd.h>
- #include <errno.h>
- #include <string.h>
-
-diff --git a/core/plug-in/stats/query_stats.cxx b/core/plug-in/stats/query_stats.cxx
-index 674f16c..10c498a 100644
---- a/core/plug-in/stats/query_stats.cxx
-+++ b/core/plug-in/stats/query_stats.cxx
-@@ -7,6 +7,7 @@
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <stdlib.h>
-+#include <unistd.h>
-
- #include <map>
- #include <string>
---
-1.6.5.6
-
diff --git a/testing/sems/0003-cc-and-cflags.patch b/testing/sems/0003-cc-and-cflags.patch
deleted file mode 100644
index a17c1f77..00000000
--- a/testing/sems/0003-cc-and-cflags.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From b411106aa364fd13e87d85e94ade9eeb1d6aeb8e Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 18 Dec 2009 09:13:58 +0000
-Subject: [PATCH] cc and cflags
-
----
- core/plug-in/binrpcctrl/Makefile | 2 +-
- core/plug-in/gsm/gsm-1.0-pl10/Makefile | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/core/plug-in/binrpcctrl/Makefile b/core/plug-in/binrpcctrl/Makefile
-index 71680f3..753779a 100644
---- a/core/plug-in/binrpcctrl/Makefile
-+++ b/core/plug-in/binrpcctrl/Makefile
-@@ -35,7 +35,7 @@ libbinrpc:
- $(MAKE) all
-
- $(LIBBINRPC_LIB)/libbinrpc.a:
-- $(MAKE) -C $(LIBBINRPC_DIR) all CC=$(CC) LD=$(LD) AR=$(AR)
-+ $(MAKE) -C $(LIBBINRPC_DIR) all CC="$(CC)" LD="$(LD)" AR="$(AR)"
-
- libbinrpc_clean:
- $(MAKE) -C $(LIBBINRPC_DIR) clean
-diff --git a/core/plug-in/gsm/gsm-1.0-pl10/Makefile b/core/plug-in/gsm/gsm-1.0-pl10/Makefile
-index 396fb7f..6a1a1a1 100644
---- a/core/plug-in/gsm/gsm-1.0-pl10/Makefile
-+++ b/core/plug-in/gsm/gsm-1.0-pl10/Makefile
-@@ -43,11 +43,11 @@ WAV49 =
- # CC = /usr/lang/acc
- # CCFLAGS = -c -O
-
--CC = gcc -ansi -pedantic
--CCFLAGS = -c -O2 -DNeedFunctionPrototypes=1 -fPIC
-+CC ?= gcc
-+CCFLAGS += -ansi -pedantic -c -O2 -DNeedFunctionPrototypes=1 -fPIC
- MODULE_CFLAGS = -I inc -DHAS_STDLIB_H
-
--LD = $(CC)
-+LD ?= $(CC)
-
- # LD = gcc
- # LDFLAGS =
---
-1.6.5.6
-
diff --git a/testing/sems/APKBUILD b/testing/sems/APKBUILD
deleted file mode 100644
index 51c3a044..00000000
--- a/testing/sems/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-pkgname=sems
-pkgver=1.1.1
-pkgrel=1
-pkgdesc="High performance, extensible media server for SIP (RFC3261) based VoIP services"
-url="http://iptel.org/sems/"
-license="GPL-2"
-depends="kamailio"
-makedepends="python-dev openssl-dev lame-dev"
-install=
-subpackages=
-source="http://ftp.iptel.org/pub/$pkgname/1.1/$pkgver/src/$pkgname-$pkgver.tar.gz
- 0001-makefile-fail-on-errors.patch
- 0002-include-headers.patch
- 0003-cc-and-cflags.patch
- "
-
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- for i in "$srcdir"/*.patch; do
- [ -f "$i" ] || continue
- patch -p1 -i $i || return 1
- done
-
- sed -i -e 's:^cfg-target.*:cfg-target = $(cfg-dir):' \
- -e 's:^cfg-prefix.*:cfg-prefix = $(basedir):' \
- Makefile.defs \
- || return 1
-}
-
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
-
- make PREFIX=/usr \
- cfg-dir=/etc/sems/ \
- CC="$CC" CXX="$CXX" \
- exclude_modules+="ivr examples py_sems speex gateway echo g722" \
- WITH_MPG123DECODER=no \
- || return 1
-}
-
-package() {
- cd "$srcdir"/$pkgname-$pkgver
- make PREFIX=/usr \
- cfg-dir=/etc/sems/ \
- exclude_modules+="ivr examples py_sems speex gateway echo g722" \
- DESTDIR="$pkgdir" \
- WITH_MPG123DECODER=no \
- install || return 1
-
- # remove the 2 lines below (and this) if there is no init.d script
-# install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-# install -m644 -D "$srcdir"//$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="4a6422d09ddadaf9eacd8cae8f0848d5 sems-1.1.1.tar.gz
-f893ceef9295b593d2b1837a538b315a 0001-makefile-fail-on-errors.patch
-3d217a6d217fa8704d108f23815d4b97 0002-include-headers.patch
-0054e6ed7e11393e71204876179d3199 0003-cc-and-cflags.patch"