summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/git/APKBUILD4
-rw-r--r--main/mpg123/APKBUILD4
-rw-r--r--main/xfce4-settings/APKBUILD33
-rw-r--r--main/xfce4-settings/xfce4-settings-4.7.1-libxklavier.patch27
-rw-r--r--main/xfce4-xkb-plugin/APKBUILD4
-rw-r--r--main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch9
6 files changed, 68 insertions, 13 deletions
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index d3823194..f27bf247 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
-pkgver=1.7.0.3
+pkgver=1.7.0.4
pkgrel=0
pkgdesc="GIT - the stupid content tracker"
url="http://git.or.cz/"
@@ -42,5 +42,5 @@ perl() {
}
-md5sums="1a449b84dd60a066ea491a54346843e6 git-1.7.0.3.tar.bz2
+md5sums="1cc8b2aea57e5e999ccac18ae355f760 git-1.7.0.4.tar.bz2
e63a201556c4f089de790805c09a2e5b bb-tar.patch"
diff --git a/main/mpg123/APKBUILD b/main/mpg123/APKBUILD
index 583f4071..f10f46b1 100644
--- a/main/mpg123/APKBUILD
+++ b/main/mpg123/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpg123
-pkgver=1.10.1
+pkgver=1.12.1
pkgrel=0
pkgdesc="A console based real time MPEG Audio Player for Layer 1, 2 and 3"
url="http://sourceforge.net/projects/mpg123"
@@ -33,4 +33,4 @@ dev() {
mv "$subpkgdir"/usr/lib/mpg123/output_* "$pkgdir"/usr/lib/mpg123/
}
-md5sums="bddabc8ae14ede213d91398a6a492f2a mpg123-1.10.1.tar.bz2"
+md5sums="e7d810a75d22954169f1530a436aca4c mpg123-1.12.1.tar.bz2"
diff --git a/main/xfce4-settings/APKBUILD b/main/xfce4-settings/APKBUILD
index 2d048cfa..ffc6ec03 100644
--- a/main/xfce4-settings/APKBUILD
+++ b/main/xfce4-settings/APKBUILD
@@ -1,21 +1,39 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfce4-settings
pkgver=4.6.4
-pkgrel=0
+pkgrel=1
pkgdesc="Settings manager for xfce"
url="http://www.xfce.org/"
license="GPL-2"
depends=
makedepends="exo-dev libnotify-dev libxfcegui4-dev libxklavier-dev libwnck-dev
libglade-dev pkgconfig intltool gettext-dev libiconv-dev expat-dev
- libxi-dev libsm-dev e2fsprogs-dev libxkbfile-dev libxrandr-dev"
-source="http://archive.xfce.org/src/xfce/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+ libxi-dev libsm-dev e2fsprogs-dev libxkbfile-dev libxrandr-dev
+ autoconf automake libtool"
+source="http://archive.xfce.org/src/xfce/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ xfce4-settings-4.7.1-libxklavier.patch
+ "
-build() {
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ [ -f "$i" ] || continue
+ msg "Applying ${i##*/}"
+ patch -p1 -i "$i" || return 1
+ done
+
+ # use tango as default icon set
sed -i -e 's/Rodent/Tango/g' xfsettingsd/xsettings.xml \
- dialogs/appearance-settings/main.c
+ dialogs/appearance-settings/main.c || return 1
+ msg "Regenerating configure script"
+ autoheader && autoconf || return 1
+}
+
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -31,4 +49,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="04985407e8e5b916c44780314a177e96 xfce4-settings-4.6.4.tar.bz2"
+md5sums="04985407e8e5b916c44780314a177e96 xfce4-settings-4.6.4.tar.bz2
+9a03696ed6200801d296c8adf6816a06 xfce4-settings-4.7.1-libxklavier.patch"
diff --git a/main/xfce4-settings/xfce4-settings-4.7.1-libxklavier.patch b/main/xfce4-settings/xfce4-settings-4.7.1-libxklavier.patch
new file mode 100644
index 00000000..142932c8
--- /dev/null
+++ b/main/xfce4-settings/xfce4-settings-4.7.1-libxklavier.patch
@@ -0,0 +1,27 @@
+diff -ur xfce4-settings-4.7.1.orig/configure.ac xfce4-settings-4.7.1/configure.ac
+--- xfce4-settings-4.7.1.orig/configure.ac 2010-01-23 13:48:05.000000000 +0200
++++ xfce4-settings-4.7.1/configure.ac 2010-02-15 14:20:55.000000000 +0200
+@@ -142,6 +142,8 @@
+ [libxklavier], [Keyboard layout selection])
+ XDT_CHECK_OPTIONAL_PACKAGE([LIBXKLAVIER4], [libxklavier], [4.0],
+ [libxklavier], [Keyboard layout selection])
++XDT_CHECK_OPTIONAL_PACKAGE([LIBXKLAVIER5], [libxklavier], [5.0],
++ [libxklavier], [Keyboard layout selection])
+
+ dnl ************************************
+ dnl *** Xsettings daemon is optional ***
+diff -ur xfce4-settings-4.7.1.orig/dialogs/keyboard-settings/xfce-keyboard-settings.c xfce4-settings-4.7.1/dialogs/keyboard-settings/xfce-keyboard-settings.c
+--- xfce4-settings-4.7.1.orig/dialogs/keyboard-settings/xfce-keyboard-settings.c 2010-01-23 13:48:05.000000000 +0200
++++ xfce4-settings-4.7.1/dialogs/keyboard-settings/xfce-keyboard-settings.c 2010-02-15 14:23:24.000000000 +0200
+@@ -395,7 +395,11 @@
+
+ #ifdef HAVE_LIBXKLAVIER
+ /* Stop xklavier engine */
++#ifdef HAVE_LIBXKLAVIER5
++ xkl_engine_stop_listen (settings->priv->xkl_engine, XKLL_TRACK_KEYBOARD_STATE);
++#else
+ xkl_engine_stop_listen (settings->priv->xkl_engine);
++#endif /* HAVE_LIBXKLAVIER5 */
+ #endif /* HAVE_LIBXKLAVIER */
+
+ g_object_unref (G_OBJECT (settings->priv->provider));
diff --git a/main/xfce4-xkb-plugin/APKBUILD b/main/xfce4-xkb-plugin/APKBUILD
index c7136cee..7b590a16 100644
--- a/main/xfce4-xkb-plugin/APKBUILD
+++ b/main/xfce4-xkb-plugin/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfce4-xkb-plugin
pkgver=0.5.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="plugin to switch keyboard layouts for the Xfce4 panel"
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
license="custom"
@@ -33,4 +33,4 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
md5sums="b233cc9de1cbace075eaf6e2c9a8e685 xfce4-xkb-plugin-0.5.3.3.tar.gz
-f805bf4d31d1a55176e479a3c253df95 xfce4-xkb-plugin-0.5.3.3-libxklavier.patch"
+781165ce1bc08059ae8e846c45c0bab2 xfce4-xkb-plugin-0.5.3.3-libxklavier.patch"
diff --git a/main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch b/main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch
index fbb91890..5b9dc540 100644
--- a/main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch
+++ b/main/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-libxklavier.patch
@@ -10,6 +10,15 @@ diff -ur xfce4-xkb-plugin-0.5.3.3.orig/panel-plugin/xkb-config.c xfce4-xkb-plugi
config_item = xkl_config_item_new ();
+@@ -214,7 +214,7 @@
+
+ gdk_window_remove_filter (NULL, (GdkFilterFunc) handle_xevent, NULL);
+
+- xkl_engine_stop_listen (config->engine);
++ xkl_engine_stop_listen (config->engine, XKLL_TRACK_KEYBOARD_STATE);
+ }
+
+ gint
@@ -547,7 +547,7 @@
if (!config) return NULL;