summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/acf-tinydns/APKBUILD4
-rw-r--r--main/acf-weblog/APKBUILD4
-rw-r--r--main/acf-weblog/acf-weblog.post-upgrade14
-rw-r--r--main/dovecot/APKBUILD3
-rw-r--r--testing/hardinfo/APKBUILD32
-rw-r--r--testing/hardinfo/fixsensors.patch13
6 files changed, 65 insertions, 5 deletions
diff --git a/main/acf-tinydns/APKBUILD b/main/acf-tinydns/APKBUILD
index 7b256601..82b9ceb2 100644
--- a/main/acf-tinydns/APKBUILD
+++ b/main/acf-tinydns/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=acf-tinydns
-pkgver=0.5.2
+pkgver=0.5.3
pkgrel=0
pkgdesc="A web-based system administration interface for tinydns"
url="http://git.alpinelinux.org/cgit/acf-tinydns"
@@ -12,4 +12,4 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-md5sums="906c2d284f4aa5a9059ae3c1c980a309 acf-tinydns-0.5.2.tar.bz2"
+md5sums="0fec252d8cef53ffe226b3adf2acb9c3 acf-tinydns-0.5.3.tar.bz2"
diff --git a/main/acf-weblog/APKBUILD b/main/acf-weblog/APKBUILD
index 6600623f..ec2f111c 100644
--- a/main/acf-weblog/APKBUILD
+++ b/main/acf-weblog/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-weblog
-pkgver=0.5.3
+pkgver=0.5.4
pkgrel=0
pkgdesc="ACF for web proxy (squid and dansguardian) logfiles"
url="http://git.alpinelinux.org/cgit/acf-weblog"
@@ -17,4 +17,4 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="ec29bf0cf9ab0a3deb892ff28d8c98bc acf-weblog-0.5.3.tar.bz2"
+md5sums="8926a8178bf646363678bc9feacbc310 acf-weblog-0.5.4.tar.bz2"
diff --git a/main/acf-weblog/acf-weblog.post-upgrade b/main/acf-weblog/acf-weblog.post-upgrade
index aec1e22c..a15590cc 100644
--- a/main/acf-weblog/acf-weblog.post-upgrade
+++ b/main/acf-weblog/acf-weblog.post-upgrade
@@ -3,6 +3,20 @@
new=$1
old=$2
+# if current is not older than 0.5.4 we exit.
+if ! [ "$(apk version -t $old 0.5.4)" = "<" ]; then
+ exit 0
+fi
+
+psql -U postgres -c "ALTER TABLE weblog ALTER bytes TYPE bigint"\
+ webproxylog
+psql -U postgres -c "ALTER TABLE pubweblog ALTER bytes TYPE bigint"\
+ webproxylog
+psql -U postgres -c "ALTER TABLE blocklog ALTER bytes TYPE bigint"\
+ webproxylog
+psql -U postgres -c "ALTER TABLE pubblocklog ALTER bytes TYPE bigint"\
+ webproxylog
+
# if current is not older than 0.4.5 we exit.
if ! [ "$(apk version -t $old 0.4.5)" = "<" ]; then
exit 0
diff --git a/main/dovecot/APKBUILD b/main/dovecot/APKBUILD
index 6fffc9ef..44901280 100644
--- a/main/dovecot/APKBUILD
+++ b/main/dovecot/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dovecot
pkgver=1.2.11
-pkgrel=0
+pkgrel=1
pkgdesc="IMAP and POP3 server"
url="http://www.dovecot.org/"
license="LGPL-2.1"
@@ -36,6 +36,7 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+ install -d "$pkgdir"/var/run/dovecot
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
diff --git a/testing/hardinfo/APKBUILD b/testing/hardinfo/APKBUILD
new file mode 100644
index 00000000..ac60f1dd
--- /dev/null
+++ b/testing/hardinfo/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hardinfo
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="A system information and benchmark tool."
+url="http://hardinfo.berlios.de/wiki/index.php/Main_Page"
+license="GPL-2"
+makedepends="gtk+-dev libsoup-dev>=2.4.0 gnutls-dev>=2.4.1"
+depends=
+source="http://download.berlios.de/$pkgname/$pkgname-$pkgver.tar.bz2
+ fixsensors.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 < "$srcdir"/fixsensors.patch || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -d "$pkgdir"/etc
+ echo "Alpine Linux" > "$pkgdir"/etc/hardinfo.distro
+}
+md5sums="6fb38992e140f2fab16518ae1f38e188 hardinfo-0.5.1.tar.bz2
+05c212db07b9f152cdea052ff7bb28fa fixsensors.patch"
diff --git a/testing/hardinfo/fixsensors.patch b/testing/hardinfo/fixsensors.patch
new file mode 100644
index 00000000..812c2945
--- /dev/null
+++ b/testing/hardinfo/fixsensors.patch
@@ -0,0 +1,13 @@
+ diff -upNr hardinfo-0.4.2.2.orign/util.c hardinfo-0.4.2.2/util.c
+--- hardinfo-0.4.2.2.orign/util.c 2007-07-20 16:45:08.000000000 +0200
++++ hardinfo-0.4.2.2/util.c 2007-07-26 10:15:32.000000000 +0200
+@@ -996,7 +996,8 @@ gchar *h_strdup_cprintf(const gchar * fo
+ if (source) {
+ retn = g_strconcat(source, buffer, NULL);
+ g_free(buffer);
+- g_free(source);
++ if(strlen(source))
++ g_free(source);
+ } else {
+ retn = buffer;
+ }