summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/pound/APKBUILD31
-rw-r--r--testing/pound/pound.cfg54
-rw-r--r--testing/pound/pound.initd26
3 files changed, 111 insertions, 0 deletions
diff --git a/testing/pound/APKBUILD b/testing/pound/APKBUILD
new file mode 100644
index 00000000..058d7f37
--- /dev/null
+++ b/testing/pound/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pound
+pkgver=2.4.5
+pkgrel=0
+pkgdesc="A reverse proxy, load balancer, and SSL wrapper"
+url="http://www.apsis.ch/pound/index_html"
+license="GPL"
+depends=
+makedepends="pcre-dev openssl-dev"
+subpackages="$pkgname-doc"
+source="http://www.apsis.ch/$pkgname/Pound-$pkgver.tgz
+ pound.cfg
+ $pkgname.initd"
+
+_builddir="$srcdir"/Pound-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --sysconfdir=/etc/pound
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/sbin
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm755 "$srcdir"/pound.initd "$pkgdir"/etc/init.d/pound
+ install -Dm644 "$srcdir"/pound.cfg "$pkgdir"/etc/pound.cfg
+}
+md5sums="4c4613e857ee14c06c61ab09e28ae503 Pound-2.4.5.tgz
+736b12a47acbb7fc2802ed7f51e959d0 pound.cfg
+074fc58c89bb70e8fcd767ee70ebd0f0 pound.initd"
diff --git a/testing/pound/pound.cfg b/testing/pound/pound.cfg
new file mode 100644
index 00000000..664ea53c
--- /dev/null
+++ b/testing/pound/pound.cfg
@@ -0,0 +1,54 @@
+## Minimal sample pound.cfg
+##
+## see pound(8) for details
+
+
+######################################################################
+## global options:
+
+User "nobody"
+Group "nobody"
+#RootJail /chroot/pound
+
+## Logging: (goes to syslog by default)
+## 0 no logging
+## 1 normal
+## 2 extended
+## 3 Apache-style (common log format)
+LogLevel 1
+
+## check backend every X secs:
+Alive 30
+
+## use hardware-accelleration card supported by openssl(1):
+#SSLEngine <hw>
+
+
+######################################################################
+## listen, redirect and ... to:
+
+## redirect all requests on port 8888 ("ListenHTTP") to the local webserver see "UrlGroup" below):
+ListenHTTP
+Address 127.0.0.1
+Port 8888
+
+## allow PUT and DELETE also (by default only GET, POST and HEAD)?:
+xHTTP 0
+
+Service
+URL ".*"
+
+BackEnd
+Address 127.0.0.1
+Port 80
+Priority 1
+
+## End Backend
+End
+
+## End Service
+End
+
+## End listener
+End
+
diff --git a/testing/pound/pound.initd b/testing/pound/pound.initd
new file mode 100644
index 00000000..13513940
--- /dev/null
+++ b/testing/pound/pound.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/files/pound.init-1.9,v 1.1 2005/07/07 15:45:08 mkennedy Exp $
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting pound"
+ if [ ! -f "/etc/pound.cfg" ]; then
+ eend 1 "configfile /etc/pound.cfg not found."
+ fi
+ start-stop-daemon --quiet --start --exec /usr/sbin/pound \
+ -- -f /etc/pound.cfg -p /var/run/pound.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pound"
+ start-stop-daemon --quiet --stop --pidfile /var/run/pound.pid
+ eend $?
+}
+