summaryrefslogtreecommitdiffstats
path: root/extra/dahdi-linux-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/dahdi-linux-grsec/APKBUILD')
-rw-r--r--extra/dahdi-linux-grsec/APKBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/extra/dahdi-linux-grsec/APKBUILD b/extra/dahdi-linux-grsec/APKBUILD
deleted file mode 100644
index 6aa68404..00000000
--- a/extra/dahdi-linux-grsec/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# Contributor: Timo Teras <timo.teras@iki.fi>
-# Maintainer: Timo Teras <timo.teras@iki.fi>
-
-_flavor=grsec
-
-# source the kernel version
-if [ -f ../../core/linux-${_flavor}/APKBUILD ]; then
- . ../../core/linux-${_flavor}/APKBUILD
-fi
-
-_abi_release=${pkgver:-2.6.29.5}-${_flavor}
-_realname=dahdi-linux
-
-pkgname=${_realname}-${_flavor}
-pkgver=2.2.0
-pkgrel=3
-pkgdesc="Digium Asterisk Hardware Device Interface drivers"
-url="http://www.asterisk.org"
-license="GPL"
-depends="dahdi-linux"
-# we need wget and tar because make install downloads firmware and uses fancy
-# options for tar and wget.
-makedepends="linux-${_flavor}-dev wget tar perl"
-install=
-subpackages=
-source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$pkgver.tar.gz
- dahdi-depmod.patch
- dahdi-bri_dchan.patch
- dahdi-zaphfc.patch
- zaphfc-dahdi-flortz.diff
- dahdi-linux-2.2.0-hfc-4s.patch
- "
-
-build() {
- cd "$srcdir/$_realname-$pkgver"
- for i in ../*.patch ../*.diff; do
- msg "Applying $i"
- patch -p1 < $i || return 1;
- done
-
- make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
- || return 1
- make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
- DESTDIR="$pkgdir" install
-}
-
-# since we sourced the APKBUILD above we got the dev() function there to
-# so we override it again.
-dev() {
- default_dev
-}
-md5sums="a6b1a24a436e1c1fd08b99d27cfe3f38 dahdi-linux-2.2.0.tar.gz
-c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
-4b41a82ff390ac64c08092c5a3eab6a8 dahdi-bri_dchan.patch
-a822c092f0548cd13f5e8d8cba053af6 dahdi-zaphfc.patch
-291c5c44c86ab02443a742415461ddca zaphfc-dahdi-flortz.diff
-68dfe17a49cca15ae439fd83f4ccfbc5 dahdi-linux-2.2.0-hfc-4s.patch"