summaryrefslogtreecommitdiffstats
path: root/extra/fcgi
diff options
context:
space:
mode:
Diffstat (limited to 'extra/fcgi')
-rw-r--r--extra/fcgi/APKBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/extra/fcgi/APKBUILD b/extra/fcgi/APKBUILD
index ff619df7..fc208006 100644
--- a/extra/fcgi/APKBUILD
+++ b/extra/fcgi/APKBUILD
@@ -21,22 +21,17 @@ build() {
patch -p1 < $i || return 1
done
- # not sure how to use autotools for this apk
- # Removed makefile patch and added libs -lm
- #aclocal || return 1
- #autoconf || return 1
- # add missing files so automake doesnt error
- #touch NEWS AUTHORS ChangeLog || return 1
- #automake --add-missing || return 1
- #libtoolize || return 1
export LIBS="$LIBS -lm"
+ # seems like there is no way to disable c++ from configure script
+ # the row below helps us to build even if g++ is installed on system
+ export CXX=false
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --enable-shared \
- --enable-static
+ --enable-shared
make || return 1
make DESTDIR="$pkgdir" install