summaryrefslogtreecommitdiffstats
path: root/extra/pinentry/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/pinentry/APKBUILD')
-rw-r--r--extra/pinentry/APKBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/extra/pinentry/APKBUILD b/extra/pinentry/APKBUILD
deleted file mode 100644
index 5322ebe7..00000000
--- a/extra/pinentry/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=pinentry
-pkgver=0.7.5
-_uiconv_ver=0.3
-pkgrel=0
-pkgdesc="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
-url="http://www.gnupg.org/aegypten2"
-license="GPL-2"
-depends="ncurses libcap"
-makedepends="ncurses-dev libcap-dev"
-subpackages="$pkgname-doc"
-source="ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.gz
- http://git.alpinelinux.org/cgit/uiconv/snapshot/uiconv-$_uiconv_ver.tar.bz2
- "
-
-build () {
- # we build it against uiconv to avoid the bloaty GNU libiconv.
- # it will be linked statically so we don't need it in depends
- cd "$srcdir/uiconv-$_uiconv_ver"
- make
- make DESTDIR="$srcdir" PREFIX=/uiconv install
-
- cd "$srcdir"/$pkgname-$pkgver
-
- # the configure script have a broken --with-libiconv-prefix option
- # so we set the -I and -L flags hard
- export CFLAGS="$CFLAGS -I $srcdir/uiconv/include"
- export LDFLAGS="$LDFLAGS -L $srcdir/uiconv/lib"
-
- ./configure --prefix=/usr \
- --disable-pinentry-gtk \
- --disable-pinentry-gtk2 \
- --disable-pinentry-qt \
- --enable-pinentry-curses \
- --enable-fallback-curses \
- --with-libiconv-prefix="$srcdir"/uiconv
-
- make || return 1
- make DESTDIR="$pkgdir" install
-}
-md5sums="ca492afbbb59cd19f1c875533f18b269 pinentry-0.7.5.tar.gz
-5cd7f80085324d08cb976fec674cd98d uiconv-0.3.tar.bz2"