summaryrefslogtreecommitdiffstats
path: root/main/abiword/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/abiword/APKBUILD')
-rw-r--r--main/abiword/APKBUILD54
1 files changed, 49 insertions, 5 deletions
diff --git a/main/abiword/APKBUILD b/main/abiword/APKBUILD
index 8007da2a..c134f199 100644
--- a/main/abiword/APKBUILD
+++ b/main/abiword/APKBUILD
@@ -1,24 +1,68 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
-pkgver=2.8.3
-pkgrel=0
+pkgver=2.8.4
+pkgrel=2
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
license="GPL"
makedepends="pkgconfig libglade-dev libgsf-dev enchant-dev fribidi-dev wv-dev
- popt-dev jpeg-dev librsvg-dev bzip2-dev"
-subpackages="$pkgname-dev"
+ popt-dev jpeg-dev librsvg-dev bzip2-dev goffice-dev"
+
+# openxml plugin
+makedepends="$makedepends boost-dev"
+
+# collab plugin
+makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
+
+
+subpackages="$pkgname-dev $pkgname-doc $pkgname-plugins"
+
+_plugins="applix babelfish bmp clarisworks collab docbook eml freetranslation
+ garble gdict gimp google hancom hrtext iscii kword loadbindings mht
+ mif mswrite openwriter openxml opml paint passepartout pdb pdf
+ presentation s5 sdw t602 urldict wikipedia wml xslfo"
+
+for _i in $_plugins; do
+ subpackages="$subpackages $pkgname-plugin-$_i:$_i"
+done
+
source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz"
build() {
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-plugins \
|| return 1
make || return 1
}
+# ="opendocument goffice latex" \
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
-md5sums="8984b09663e1514ca0e361b0627ea285 abiword-2.8.3.tar.gz"
+
+_do_plugin() {
+ local plugin="$1"
+ pkgdesc="Abiword $1 plugin"
+ local dir="usr/lib/abiword-${pkgver%.*}/plugins"
+ mkdir -p "$subpkgdir"/$dir
+ mv "$pkgdir"/$dir/$plugin.so "$subpkgdir"/$dir/
+}
+
+for _i in $_plugins; do
+ eval "$_i() { _do_plugin $_i; }"
+done
+
+plugins() {
+ pkgdesc="Abiword plugins, all of them"
+ depends=
+ for _i in $_plugins; do
+ depends="$depends $pkgname-plugin-$_i"
+ done
+ mkdir -p "$subpkgdir"
+}
+
+md5sums="f782ecb8e07d07ec179f7a143353cc29 abiword-2.8.4.tar.gz"