summaryrefslogtreecommitdiffstats
path: root/main/apk-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/apk-tools/APKBUILD')
-rw-r--r--main/apk-tools/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 96d7d35b..7db8f8a3 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.0_pre17
-pkgrel=1
+pkgrel=2
pkgdesc="Alpine Package Keeper - package manager for alpine"
depends=
makedepends="zlib-dev openssl-dev pkgconfig"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
0001-db-fix-checksum-storing-to-db.patch
+ 0001-io-fix-corruption-of-big-files-on-mmap-write.patch
"
@@ -17,6 +18,8 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's:-Werror::' Make.rules
patch -p1 -i ../0001-db-fix-checksum-storing-to-db.patch || return 1
+ patch -p1 -i ../0001-io-fix-corruption-of-big-files-on-mmap-write.patch\
+ || return 1
make || return 1
make DESTDIR="$pkgdir" install
@@ -30,4 +33,5 @@ build() {
}
md5sums="4d31c9ae51b357a8514e99a8750af0b6 apk-tools-2.0_pre17.tar.bz2
-d7944308cefe6f5fc45a24e1840d087e 0001-db-fix-checksum-storing-to-db.patch"
+d7944308cefe6f5fc45a24e1840d087e 0001-db-fix-checksum-storing-to-db.patch
+57693255bb36abe74423578b83ff2cf4 0001-io-fix-corruption-of-big-files-on-mmap-write.patch"