summaryrefslogtreecommitdiffstats
path: root/main/busybox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/busybox/APKBUILD')
-rw-r--r--main/busybox/APKBUILD46
1 files changed, 38 insertions, 8 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index bd0f178f..d379e5a8 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,19 +1,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.16.1
-pkgrel=0
+pkgrel=4
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
depends=
install="$pkgname.post-install $pkgname.post-upgrade"
+subpackages="$pkgname-static"
triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-1.11.1-bb.patch
flock-bb.patch
+ http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-ash.patch
+ http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-cpio.patch
+ http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-dhcpd.patch
+ http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-dnsd.patch
+ http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-hwclock.patch
+ http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-indexcgi.patch
+ http://busybox.net/downloads/fixes-1.16.1/busybox-1.16.1-sed.patch
busyboxconfig"
_builddir="$srcdir"/$pkgname-$pkgver
+_config="$srcdir"/busyboxconfig
prepare() {
cd "$_builddir"
#patches
@@ -28,30 +37,51 @@ prepare() {
sed -i -e 's/(ip, _BB_DIR_BIN/(ip, _BB_DIR_SBIN/' \
-e 's/(vi, _BB_DIR_BIN/(vi, _BB_DIR_USR_BIN/' \
include/applets.h || return 1
-
- # we set the install prefix with sed since it might differ depending
- # on abuild version
- sed -e "s:^CONFIG_PREFIX=.*:CONFIG_PREFIX=\"$pkgdir\":" \
- ../busyboxconfig > .config
}
build() {
cd "$_builddir"
+ msg "Building static busybox"
+ sed -e "s/.*CONFIG_PIE.*/\# CONFIG_PIE is not set/" \
+ -e "s/.*CONFIG_STATIC.*/CONFIG_STATIC=y/" \
+ "$_config" > .config
+ make silentoldconfig || return 1
+ make || return 1
+ mv busybox busybox.static
+
+ # build dynamic
+ msg "Building dynamic busybox"
+ cp "$_config" .config
make silentoldconfig || return 1
make || return 1
}
package() {
cd "$_builddir"
- make install DESTDIR="$pkgdir"
mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin "$pkgdir"/tmp \
- "$pkgdir"/var/cache/misc
+ "$pkgdir"/var/cache/misc "$pkgdir"/bin "$pkgdir"/sbin
chmod 1777 "$pkgdir"/tmp
+ install -m755 busybox "$pkgdir"/bin/busybox
# we need /bin/sh to be able to execute post-install
ln -s /bin/busybox "$pkgdir"/bin/sh
}
+static() {
+ triggers=
+ mkdir -p "$subpkgdir"/bin
+ install -m755 "$_builddir"/busybox.static \
+ "$subpkgdir"/bin/busybox.static
+
+}
+
md5sums="319486ec65078d07fde26eb620fecde7 busybox-1.16.1.tar.bz2
4c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
20d9beea7d0c0aaca14553a8f98fee12 flock-bb.patch
+b328c15e90c58c44f283838f224c3c97 busybox-1.16.1-ash.patch
+301feec832c938c235d370ae09f90713 busybox-1.16.1-cpio.patch
+54607ef7a80b6c3aa397788ce9166cc3 busybox-1.16.1-dhcpd.patch
+9fd18c9833253119996039429bee1992 busybox-1.16.1-dnsd.patch
+b16ad6491dcb4f053f84ae2c4064918d busybox-1.16.1-hwclock.patch
+c3bc34309334c456b6f905f0708c914f busybox-1.16.1-indexcgi.patch
+8e1ef2dc70aaaa6f1af1d5e0541de103 busybox-1.16.1-sed.patch
4bc85af9dd659cbb83c9a819b3481a47 busyboxconfig"