summaryrefslogtreecommitdiffstats
path: root/main/groff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/groff/APKBUILD')
-rw-r--r--main/groff/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/groff/APKBUILD b/main/groff/APKBUILD
new file mode 100644
index 00000000..6866c2db
--- /dev/null
+++ b/main/groff/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=groff
+pkgver=1.20.1
+pkgrel=1
+pkgdesc="GNU troff text-formatting system"
+url="http://www.gnu.org/software/groff/groff.html"
+license="GPL"
+depends="uclibc uclibc++ libgcc"
+makedepends="perl texinfo uclibc++-dev"
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ export CXX=g++-uc
+ ./configure --prefix=/usr --without-x
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="48fa768dd6fdeb7968041dd5ae8e2b02 groff-1.20.1.tar.gz"