summaryrefslogtreecommitdiffstats
path: root/main/hunspell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/hunspell/APKBUILD')
-rw-r--r--main/hunspell/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
index 6883855a..efd3476c 100644
--- a/main/hunspell/APKBUILD
+++ b/main/hunspell/APKBUILD
@@ -1,23 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hunspell
-pkgver=1.2.8
+pkgver=1.2.11
pkgrel=0
pkgdesc="Spell checker and morphological analyzer library and program"
url="http://hunspell.sourceforge.net/"
license="GPL LGPL MPL"
subpackages="$pkgname-dev $pkgname-doc"
-depends="libgcc uclibc++"
-makedepends="uclibc++-dev"
+depends=
+makedepends=
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
build ()
{
cd "$srcdir/hunspell-$pkgver"
- export CXX="${CXX_UC:-g++-uc}"
-
./configure --prefix=/usr --disable-static || return 1
make || return 1
- make DESTDIR="$pkgdir" install || return 1
+}
+
+package() {
+ cd "$srcdir/hunspell-$pkgver"
+ make -j1 DESTDIR="$pkgdir" install || return 1
rm -rf "$pkgdir"/usr/share/locale/locale.alias
}
-md5sums="1177af54a09e320d2c24015f29c3a93e hunspell-1.2.8.tar.gz"
+md5sums="8f57cdc4db091d69e1f682ed4d8ab282 hunspell-1.2.11.tar.gz"