summaryrefslogtreecommitdiffstats
path: root/main/iftop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/iftop/APKBUILD')
-rw-r--r--main/iftop/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/main/iftop/APKBUILD b/main/iftop/APKBUILD
new file mode 100644
index 00000000..644a2edc
--- /dev/null
+++ b/main/iftop/APKBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iftop
+pkgver=0.17
+pkgrel=0
+pkgdesc="iftop does for network usage what top(1) does for CPU usage"
+url="http://www.ex-parrot.com/~pdw/iftop/"
+license="GPL"
+depends=
+makedepends="libpcap-dev>=1 ncurses-dev"
+subpackages="$pkgname-doc"
+source="http://www.ex-parrot.com/~pdw/$pkgname/download/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+ make DESTDIR="$pkgdir" install
+}
+md5sums="062bc8fb3856580319857326e0b8752d iftop-0.17.tar.gz"