summaryrefslogtreecommitdiffstats
path: root/main/libspf2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libspf2/APKBUILD')
-rw-r--r--main/libspf2/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/libspf2/APKBUILD b/main/libspf2/APKBUILD
new file mode 100644
index 00000000..266147d8
--- /dev/null
+++ b/main/libspf2/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libspf2
+pkgver=1.2.9
+pkgrel=0
+pkgdesc="Sender Policy Framework library, a part of the SPF/SRS protocol pair."
+url="http://www.libspf2.org"
+license="LGPL-2.1 BSD-2"
+subpackages="$pkgname-dev"
+makedepends=
+depends=
+source="http://www.libspf2.org/spf/libspf2-$pkgver.tar.gz
+ libspf2-localpolicy-fix.patch"
+
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch; do
+ msg "Apply $i"
+ patch -p1 < $i || return 1
+ done
+ ./configure --prefix=/usr \
+ || return 1
+ # uclibc claims to have res_ninit() but it doesnt.
+ sed -i -e 's:HAVE_DECL_RES_NINIT 1:HAVE_DECL_RES_NINIT 0:' config.h
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="3305df4d1b13ca964d80b23bb5e4e2b6 libspf2-1.2.9.tar.gz
+48d82a6af8c513d75a7402f2933b8b0a libspf2-localpolicy-fix.patch"