summaryrefslogtreecommitdiffstats
path: root/main/pinentry/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/pinentry/APKBUILD')
-rw-r--r--main/pinentry/APKBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/main/pinentry/APKBUILD b/main/pinentry/APKBUILD
index b211173f..3f08adac 100644
--- a/main/pinentry/APKBUILD
+++ b/main/pinentry/APKBUILD
@@ -1,42 +1,44 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pinentry
-pkgver=0.7.6
+pkgver=0.8.0
_uiconv_ver=0.3
pkgrel=0
pkgdesc="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
url="http://www.gnupg.org/aegypten2"
license="GPL-2"
-depends="ncurses libcap"
-makedepends="ncurses-dev libcap-dev"
-subpackages="$pkgname-doc"
+depends=
+install="pinentry.post-install pinentry.post-deinstall"
+makedepends="ncurses-dev libcap-dev gtk+-dev"
+subpackages="$pkgname-doc $pkgname-gtk"
source="ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.gz
http://git.alpinelinux.org/cgit/uiconv/snapshot/uiconv-$_uiconv_ver.tar.bz2
"
build () {
- # we build it against uiconv to avoid the bloaty GNU libiconv.
- # it will be linked statically so we don't need it in depends
- cd "$srcdir/uiconv-$_uiconv_ver"
- make
- make DESTDIR="$srcdir" PREFIX=/uiconv install
-
cd "$srcdir"/$pkgname-$pkgver
-
- # the configure script have a broken --with-libiconv-prefix option
- # so we set the -I and -L flags hard
- export CFLAGS="$CFLAGS -I $srcdir/uiconv/include"
- export LDFLAGS="$LDFLAGS -L $srcdir/uiconv/lib"
-
./configure --prefix=/usr \
--disable-pinentry-gtk \
- --disable-pinentry-gtk2 \
+ --enable-pinentry-gtk2 \
--disable-pinentry-qt \
--enable-pinentry-curses \
- --enable-fallback-curses \
- --with-libiconv-prefix="$srcdir"/uiconv
+ --enable-pinentry-gtk2 \
+ --enable-fallback-curses
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
+ # created by post install scripts so we can override with gtk version
+ rm -f "$pkgdir"/usr/bin/pinentry
+}
+
+gtk() {
+ install="pinentry-gtk.post-install pinentry-gtk.post-deinstall"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/pinentry-gtk* "$subpkgdir"/usr/bin/
}
-md5sums="5a4f676375fa882009da02013d77210f pinentry-0.7.6.tar.gz
+
+md5sums="590be1b00f9ab63205843c7fed8caf35 pinentry-0.8.0.tar.gz
5cd7f80085324d08cb976fec674cd98d uiconv-0.3.tar.bz2"