summaryrefslogtreecommitdiffstats
path: root/main/valgrind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/valgrind/APKBUILD')
-rw-r--r--main/valgrind/APKBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/main/valgrind/APKBUILD b/main/valgrind/APKBUILD
index dcba2983..0465ac4a 100644
--- a/main/valgrind/APKBUILD
+++ b/main/valgrind/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=valgrind
-pkgver=3.4.1
-pkgrel=1
+pkgver=3.5.0
+pkgrel=0
pkgdesc="A tool to help find memory-management problems in programs"
url="http://valgrind.org/"
license="GPL"
-depends="uclibc"
+depends=""
# it seems like busybox sed works but the configure script requires GNU sed
makedepends="sed paxctl pax-utils"
# from README_PACKAGERS:
@@ -16,26 +16,29 @@ makedepends="sed paxctl pax-utils"
options="!strip"
subpackages="$pkgname-dev $pkgname-doc"
source="http://$pkgname.org/downloads/$pkgname-$pkgver.tar.bz2
- $pkgname-3.4.0-uclibc.patch
"
-build() {
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
local i
- cd "$srcdir/$pkgname-$pkgver"
- for i in ../*.patch; do
+ for i in "$srcdir"/*.patch; do
+ [ -f "$i" ] || continue
msg "Applying $i"
patch -p1 < $i || return 1
done
+}
- # make sure our CFLAGS are respected
- sed -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long -fno-stack-protector":' \
- -i configure.in
-
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--without-mpicc \
--mandir=/usr/share/man || return 1
-
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
# we have options=!strip above so we strip the /usr/bin/* manually
@@ -46,10 +49,9 @@ build() {
# pax causes some issues
# http://marc.info/?l=gentoo-hardened&m=119512627126298&w=2
- scanelf "$pkgdir"/usr/lib/valgrind/x86-linux \
- | awk '$1 == "ET_EXEC" {print $2}' | xargs paxctl -c -m
+# scanelf "$pkgdir"/usr/lib/valgrind/x86-linux \
+# | awk '$1 == "ET_EXEC" {print $2}' | xargs paxctl -c -m
}
-md5sums="b5f039dd2271aaf9ae570ab4116f87c7 valgrind-3.4.1.tar.bz2
-37bc90d0783bc0f8ba5754c8407e3dcc valgrind-3.4.0-uclibc.patch"
+md5sums="f03522a4687cf76c676c9494fcc0a517 valgrind-3.5.0.tar.bz2"