summaryrefslogtreecommitdiffstats
path: root/main/vim/vimrc
diff options
context:
space:
mode:
Diffstat (limited to 'main/vim/vimrc')
-rw-r--r--main/vim/vimrc15
1 files changed, 15 insertions, 0 deletions
diff --git a/main/vim/vimrc b/main/vim/vimrc
new file mode 100644
index 00000000..e3017342
--- /dev/null
+++ b/main/vim/vimrc
@@ -0,0 +1,15 @@
+set nocompatible " Use Vim defaults (much better!)
+set bs=2 " Allow backspacing over everything in insert mode
+set ai " Always set auto-indenting on
+set history=50 " keep 50 lines of command history
+set ruler " Show the cursor position all the time
+
+" Don't use Ex mode, use Q for formatting
+map Q gq
+
+" When doing tab completion, give the following files lower priority.
+set suffixes+=.info,.aux,.log,.dvi,.bbl,.out,.o,.lo
+
+set nomodeline
+syntax on
+autocmd BufRead APKBUILD set filetype=sh