summaryrefslogtreecommitdiffstats
path: root/main/xe-guest-utilities/no_hard_links.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/xe-guest-utilities/no_hard_links.patch')
-rw-r--r--main/xe-guest-utilities/no_hard_links.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/xe-guest-utilities/no_hard_links.patch b/main/xe-guest-utilities/no_hard_links.patch
new file mode 100644
index 00000000..c10918f3
--- /dev/null
+++ b/main/xe-guest-utilities/no_hard_links.patch
@@ -0,0 +1,11 @@
+--- xe-guest-utilities-5.5.0.orig/uclibc-sources/tools/xenstore/Makefile
++++ xe-guest-utilities-5.5.0/uclibc-sources/tools/xenstore/Makefile
+@@ -97,7 +97,7 @@
+ $(INSTALL_DIR) $(DESTDIR)/usr/bin
+ $(INSTALL_PROG) xenstore $(DESTDIR)/usr/bin
+ set -e ; for c in $(CLIENTS) ; do \
+- ln -f $(DESTDIR)/usr/bin/xenstore $(DESTDIR)/usr/bin/$${c} ; \
++ ln -sf $(DESTDIR)/usr/bin/xenstore $(DESTDIR)/usr/bin/$${c} ; \
+ done
+
+ .PHONY: install