summaryrefslogtreecommitdiffstats
path: root/testing/bacula/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bacula/APKBUILD')
-rw-r--r--testing/bacula/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/testing/bacula/APKBUILD b/testing/bacula/APKBUILD
index a8e977ef..052b7f3a 100644
--- a/testing/bacula/APKBUILD
+++ b/testing/bacula/APKBUILD
@@ -43,7 +43,9 @@ build() {
--infodir=/usr/share/info \
--with-pid-dir=/var/run \
--with-subsys-dir=/var/lock/subsys \
+ --with-logdir=/var/log/bacula \
--enable-largefile \
+ --enable-smartalloc \
--disable-nls \
--with-openssl=/usr/include/openssl \
--with-postgresql \
@@ -55,9 +57,10 @@ build() {
--with-sd-group=bacula \
--with-fd-user=root \
--with-fd-group=root \
- --with-dir-password=pie9Sah6aZo4aiS5te5e \
- --with-fd-password=ca4pheexie1aeC1hee3i \
- --with-sd-password=Saphaech3xohmuDaDaLi
+ --with-dir-password=PuemReTsKKObLe3TTaU73a3dPWwISW \
+ --with-fd-password=Mbh1ujsgZ2ogRFVjPWD9TAVMFP6o8E \
+ --with-sd-password=icpaksuq0gpDStLT8Uqgk1HIozFnx1 \
+ --with-db-password=BQrlfPPfdXdMHlJID0HrGHZde2Lqd9
make || return 1
}
@@ -68,19 +71,21 @@ package() {
for DAEMON in dir sd fd
do
- install -Dm755 $srcdir/bacula-${DAEMON}-init \
- $pkgdir/etc/init.d/bacula-${DAEMON}
- install -Dm644 $srcdir/bacula-${DAEMON}-conf \
- $pkgdir/etc/conf.d/bacula-${DAEMON}
+ install -Dm755 "$srcdir"/bacula-${DAEMON}-init \
+ "$pkgdir"/etc/init.d/bacula-${DAEMON}
+ install -Dm644 "$srcdir"/bacula-${DAEMON}-conf \
+ "$pkgdir"/etc/conf.d/bacula-${DAEMON}
done
+ install -Dm644 examples/sample-query.sql "$pkgdir"/etc/bacula/scripts/query.sql
+ mkdir -p "$pkgdir"/var/log/bacula
}
md5sums="68e008d2578a6d9a50af60439db17dcb bacula-5.0.0.tar.gz
-2e11ca528feb60adc1bb09a6488eb654 bacula-dir-init
+b1b328013634c98119663730e3e2da7e bacula-dir-init
20f28a16f34e3f20ed18ed81b010e765 bacula-dir-conf
-38603c86eae43e8a38962bb8590c41dd bacula-sd-init
+5ae1fba6860a320394d65744e5640bdb bacula-sd-init
afe2f9a4d79d7d96eb9372d003d10f86 bacula-sd-conf
-38b0fe78acdc5e65aec3a59578e98a20 bacula-fd-init
+6ae93e570f95fa845fa534c2d2efaac0 bacula-fd-init
4500ce2d62bf9df33c07f70dc40f7b85 bacula-fd-conf
ebc9c2bbc9be95c920723a3f142d8e19 configure.in.patch
cf7a2a4e972697f54364654c4e282b8b os.m4.patch"