summaryrefslogtreecommitdiffstats
path: root/testing/bacula/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bacula/APKBUILD')
-rw-r--r--testing/bacula/APKBUILD86
1 files changed, 86 insertions, 0 deletions
diff --git a/testing/bacula/APKBUILD b/testing/bacula/APKBUILD
new file mode 100644
index 00000000..6adc4945
--- /dev/null
+++ b/testing/bacula/APKBUILD
@@ -0,0 +1,86 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname="bacula"
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="Enterprise ready, network based backup program"
+url="http://www.bacula.org"
+license="GPL2"
+depends="postgresql openssl ncurses"
+makedepends="postgresql-dev openssl-dev ncurses-dev autoconf"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
+bacula-dir-init
+bacula-dir-conf
+bacula-sd-init
+bacula-sd-conf
+bacula-fd-init
+bacula-fd-conf
+configure.in.patch
+os.m4.patch"
+
+prepare () {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < ../../configure.in.patch
+ patch -p1 < ../../os.m4.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ export LDFLAGS=
+ # Need to run configure at least once
+ # in order to do not go into an infinite loop
+ ./configure
+ make configure
+ make distclean
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/bacula \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc \
+ --infodir=/usr/share/info \
+ --with-pid-dir=/var/run \
+ --with-subsys-dir=/var/lock/subsys \
+ --enable-largefile \
+ --disable-nls \
+ --with-openssl=/usr/include/openssl \
+ --with-postgresql=/usr \
+ --with-scriptdir=/etc/bacula/scripts \
+ --with-working-dir=/var/bacula \
+ --with-dir-user=bacula \
+ --with-dir-group=bacula \
+ --with-sd-user=bacula \
+ --with-sd-group=bacula \
+ --with-fd-user=root \
+ --with-fd-group=root \
+ --with-dir-password=pie9Sah6aZo4aiS5te5e \
+ --with-fd-password=ca4pheexie1aeC1hee3i \
+ --with-sd-password=Saphaech3xohmuDaDaLi
+
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ for DAEMON in dir sd fd
+ do
+ install -Dm755 $srcdir/bacula-${DAEMON}-init \
+ $pkgdir/etc/init.d/bacula-${DAEMON}
+ install -Dm644 $srcdir/bacula-${DAEMON}-conf \
+ $pkgdir/etc/conf.d/bacula-${DAEMON}
+ done
+}
+
+md5sums="feba58691b674b12056359d459ad6940 bacula-3.0.3.tar.gz
+2e11ca528feb60adc1bb09a6488eb654 bacula-dir-init
+20f28a16f34e3f20ed18ed81b010e765 bacula-dir-conf
+38603c86eae43e8a38962bb8590c41dd bacula-sd-init
+afe2f9a4d79d7d96eb9372d003d10f86 bacula-sd-conf
+38b0fe78acdc5e65aec3a59578e98a20 bacula-fd-init
+4500ce2d62bf9df33c07f70dc40f7b85 bacula-fd-conf
+ebc9c2bbc9be95c920723a3f142d8e19 configure.in.patch
+cf7a2a4e972697f54364654c4e282b8b os.m4.patch"