summaryrefslogtreecommitdiffstats
path: root/testing/cherokee
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cherokee')
-rw-r--r--testing/cherokee/APKBUILD38
-rw-r--r--testing/cherokee/cherokee.confd10
-rwxr-xr-xtesting/cherokee/cherokee.initd41
3 files changed, 89 insertions, 0 deletions
diff --git a/testing/cherokee/APKBUILD b/testing/cherokee/APKBUILD
new file mode 100644
index 00000000..47a7d43a
--- /dev/null
+++ b/testing/cherokee/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=cherokee
+pkgver=0.99.41
+pkgrel=0
+pkgdesc="A very fast, flexible and easy to configure Web Server"
+url="http://www.cherokee-project.com/"
+license="GPL2"
+depends="pcre rrdtool"
+makedepends="openssl-dev gettext-dev ffmpeg-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.cherokee-project.com/download/0.99/${pkgver}/${pkgname}-${pkgver}.tar.gz
+ cherokee.initd
+ cherokee.confd
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --with-wwwroot=/var/www
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="388affc0636aca802ec46cea4ebb8d08 cherokee-0.99.41.tar.gz
+4180dbb6701f928054079aa1e3bd5ebc cherokee.initd
+bd6a840f72c630ce1eaabe058097584f cherokee.confd"
diff --git a/testing/cherokee/cherokee.confd b/testing/cherokee/cherokee.confd
new file mode 100644
index 00000000..8f719df3
--- /dev/null
+++ b/testing/cherokee/cherokee.confd
@@ -0,0 +1,10 @@
+# Sample conf.d file for alpine linux
+
+#
+# Specify daemon $OPTS here.
+#
+
+OPTS="-d"
+DAEMON_USER="root"
+DAEMON_GROUP="root"
+
diff --git a/testing/cherokee/cherokee.initd b/testing/cherokee/cherokee.initd
new file mode 100755
index 00000000..6aed337b
--- /dev/null
+++ b/testing/cherokee/cherokee.initd
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+
+# Cherokee init.d file for alpine linux.
+
+NAME=cherokee
+DAEMON=/usr/sbin/$NAME
+DAEMON_USER=${DAEMON_USER:-root}
+DAEMON_GROUP=${DAEMON_GROUP:-root}
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/${NAME}.pid \
+ --chuid ${DAEMON_USER}:${DAEMON_GROUP} \
+ --exec ${DAEMON} -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ start-stop-daemon --stop --quiet \
+ --exec ${DAEMON} \
+ --pidfile /var/run/${NAME}.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${NAME}"
+ if ! service_started "${NAME}" ; then
+ eend 1 "${NAME} is not started"
+ return 1
+ fi
+ start-stop-daemon --stop --oknodo --signal HUP \
+ --exec ${DAEMON} --pidfile /var/run/${NAME}.pid
+ eend $?
+}
+