summaryrefslogtreecommitdiffstats
path: root/testing/cryptsetup
diff options
context:
space:
mode:
Diffstat (limited to 'testing/cryptsetup')
-rw-r--r--testing/cryptsetup/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/cryptsetup/APKBUILD b/testing/cryptsetup/APKBUILD
new file mode 100644
index 00000000..4d7d4c98
--- /dev/null
+++ b/testing/cryptsetup/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=cryptsetup
+pkgver=1.0.7
+pkgrel=0
+pkgdesc="Userspace setup tool for transparent encryption of block devices using the Linux 2.6 cryptoapi"
+url="http://code.google.com/p/cryptsetup/"
+license="GPL"
+depends=
+makedepends="lvm2-dev libgcrypt-dev popt-dev util-linux-ng-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
+md5sums="5eea2a77391a8a1a651b31cbaef59e22 cryptsetup-1.0.7.tar.bz2"