summaryrefslogtreecommitdiffstats
path: root/testing/ebtables/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ebtables/APKBUILD')
-rw-r--r--testing/ebtables/APKBUILD58
1 files changed, 0 insertions, 58 deletions
diff --git a/testing/ebtables/APKBUILD b/testing/ebtables/APKBUILD
deleted file mode 100644
index 4bdc882e..00000000
--- a/testing/ebtables/APKBUILD
+++ /dev/null
@@ -1,58 +0,0 @@
-# Contributor: Andrew Manison <amanison@anselsystems.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=ebtables
-pkgver=2.0.9.1
-_realver=v2.0.9-1
-pkgrel=0
-pkgdesc="Ethernet bridge tables - Linux Ethernet filter for the Linux bridge."
-url="http://ebtables.sourceforge.net/"
-license="GPL"
-depends=
-makedepends=
-install=
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz
- 0001-link-with-gcc.patch
- ebtables.initd
- ebtables.confd"
-
-prepare() {
- cd "$srcdir"/$pkgname-$_realver
- # patches
- for i in ../*.patch; do
- msg "Applying $i"
- if ! patch --verbose -p1 -i $i; then
- error "$i failed"
- return 1
- fi
- done
-
- sed -i -e "s,^MANDIR:=.*,MANDIR:=/usr/share/man," \
- -e "s,^BINDIR:=.*,BINDIR:=/sbin," \
- -e "s,^INITDIR:=.*,INITDIR:=/usr/share/doc/ebtables," \
- -e "s,^SYSCONFIGDIR:=.*,SYSCONFIGDIR:=/usr/share/doc/ebtables,"\
- -e "s,^LIBDIR:=.*,LIBDIR:=/usr/lib/\$(PROGNAME)," \
- -e "s/^CFLAGS:=/CFLAGS+=/" \
- -e "s,^CC:=,CC?=," Makefile
-}
-
-build() {
- cd "$srcdir"/$pkgname-$_realver
-
- # This package uses _init functions to initialise extensions. With
- # --as-needed this will not work.
- export LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
- make || return 1
-}
-
-package() {
- cd "$srcdir"/$pkgname-$_realver
- make DESTDIR="$pkgdir" install
- install -D -m755 ../ebtables.initd "$pkgdir"/etc/init.d/ebtables
- install -D -m644 ../ebtables.initd "$pkgdir"/etc/conf.d/ebtables
-}
-
-md5sums="0e0c20adf2bba6d91dbd0b74a1a38c33 ebtables-v2.0.9-1.tar.gz
-91a565a5906dc1fd4103f03c6a88e0e1 0001-link-with-gcc.patch
-92e13b3bc1d47d7c00636ebb78c905d5 ebtables.initd
-285089ba2d846e72e321a12e3da3cc96 ebtables.confd"