summaryrefslogtreecommitdiffstats
path: root/testing/fuse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/fuse/APKBUILD')
-rw-r--r--testing/fuse/APKBUILD62
1 files changed, 0 insertions, 62 deletions
diff --git a/testing/fuse/APKBUILD b/testing/fuse/APKBUILD
deleted file mode 100644
index 52cf280b..00000000
--- a/testing/fuse/APKBUILD
+++ /dev/null
@@ -1,62 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=fuse
-pkgver=2.8.1
-pkgrel=0
-pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
-url="http://fuse.sourceforge.net/"
-license="GPL2"
-depends=
-makedepends="pkgconfig libiconv-dev gettext-dev
- autoconf automake libtool"
-install=
-subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- fuse-iconv.patch
- fuse.initd"
-
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- patch -p1 -i "$srcdir"/fuse-iconv.patch || return 1
- aclocal -I m4 && libtoolize && autoconf && automake
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --enable-lib \
- --enable-util \
- --bindir=/bin \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-
- rm -rf "$pkgdir"/dev
- rm -rf "$pkgdir"/etc/init.d
-
- install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
- # create config
- install -d "$pkgdir"/etc
- cat >"$pkgdir"/etc/fuse.conf << _EOF_
-# Set the maximum number of FUSE mounts allowed to non-root users.
-# The default is 1000.
-#
-#mount_max = 1000
-
-# Allow non-root users to specify the 'allow_other' or 'allow_root'
-# mount options.
-#
-#user_allow_other
-_EOF_
-
-}
-
-md5sums="0e3505ce90155983f1bc995eb2cf6fa7 fuse-2.8.1.tar.gz
-e5183506aabc5bf7795da52953d38888 fuse-iconv.patch
-5983726cfabf0830dffbbbf9a3abcddc fuse.initd"