summaryrefslogtreecommitdiffstats
path: root/testing/hardinfo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hardinfo/APKBUILD')
-rw-r--r--testing/hardinfo/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/testing/hardinfo/APKBUILD b/testing/hardinfo/APKBUILD
index ac60f1dd..8b6db2bf 100644
--- a/testing/hardinfo/APKBUILD
+++ b/testing/hardinfo/APKBUILD
@@ -1,19 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hardinfo
pkgver=0.5.1
-pkgrel=0
+pkgrel=2
pkgdesc="A system information and benchmark tool."
url="http://hardinfo.berlios.de/wiki/index.php/Main_Page"
license="GPL-2"
makedepends="gtk+-dev libsoup-dev>=2.4.0 gnutls-dev>=2.4.1"
depends=
source="http://download.berlios.de/$pkgname/$pkgname-$pkgver.tar.bz2
- fixsensors.patch"
+ fixsensors.patch
+ hardinfo-alpine.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -p1 < "$srcdir"/fixsensors.patch || return 1
+ patch -p1 -i "$srcdir"/fixsensors.patch || return 1
+ patch -p1 -i "$srcdir"/hardinfo-alpine.patch || return 1
+ # configure scrip says bash but bb ash works just fine
+ sed -i -e '1,1s/bash/sh/' configure
}
build() {
@@ -29,4 +33,5 @@ package() {
echo "Alpine Linux" > "$pkgdir"/etc/hardinfo.distro
}
md5sums="6fb38992e140f2fab16518ae1f38e188 hardinfo-0.5.1.tar.bz2
-05c212db07b9f152cdea052ff7bb28fa fixsensors.patch"
+05c212db07b9f152cdea052ff7bb28fa fixsensors.patch
+ae8d38e5b35fb2c9c5f425dde3ba27cb hardinfo-alpine.patch"