summaryrefslogtreecommitdiffstats
path: root/testing/kamailio
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kamailio')
-rw-r--r--testing/kamailio/APKBUILD23
-rw-r--r--testing/kamailio/kamailio-3-backslash.patch36
-rw-r--r--testing/kamailio/kamailio-backslash.patch15
3 files changed, 49 insertions, 25 deletions
diff --git a/testing/kamailio/APKBUILD b/testing/kamailio/APKBUILD
index 5e3a0c63..fff29082 100644
--- a/testing/kamailio/APKBUILD
+++ b/testing/kamailio/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=kamailio
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc="Open Source SIP Server"
url="http://www.kamailio.org/"
@@ -14,25 +14,28 @@ makedepends="bison flex expat-dev postgresql-dev pcre-dev
install=
subpackages="$pkgname-doc $pkgname-postgres
$pkgname-mediaproxy $pkgname-unixodbc"
-source="http://sip-router.org/tarballs/sr/kamailio_3.0/kamailio-${pkgver}_src_2010-01-12_6d1e9f.tar.gz
+source="http://www.kamailio.org/pub/kamailio/$pkgver/src/kamailio-${pkgver}_src.tar.gz
kamailio.cfg
kamailio.initd
kamailio.pre-install
kamailio.post-install
- kamailio-backslash.patch
+ kamailio-3-backslash.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
+_modules="db_postgres mediaproxy db_unixodbc carrierroute xmlrpc"
prepare() {
cd "$_builddir"
- patch -p1 -i "$srcdir"/kamailio-backslash.patch || return 1
+ patch -p1 -i "$srcdir"/kamailio-3-backslash.patch || return 1
- sed -i -e 's:^cfg-target.*:cfg-target = $(cfg-dir):' \
- -e 's:^cfg-prefix.*:cfg-prefix = $(basedir):' \
+ sed -i \
-e "s:-O9 -funroll-loops:$CFLAGS:g" \
Makefile.defs \
|| return 1
+# -e 's:^cfg-target.*:cfg-target = $(cfg-dir):' \
+# -e 's:^cfg-prefix.*:cfg-prefix = $(basedir):' \
+
cd utils/kamctl/
sed -i -e 's:/var/run/kamailio.pid:/var/run/kamailio/kamailio.pid:g' \
kamctl.base kamctlrc || return 1
@@ -55,7 +58,7 @@ build() {
MODS_PRESENCE=yes \
MODS_RADIUS= \
TLS= \
- include_modules="db_postgres mediaproxy db_unixodbc carrierroute" \
+ include_modules="$_modules" \
all || return 1
}
@@ -68,7 +71,7 @@ package() {
MODS_PRESENCE=yes \
MODS_RADIUS= \
TLS= \
- include_modules="db_postgres mediaproxy db_unixodbc carrierroute" \
+ include_modules="$_modules" \
basedir="$pkgdir" install || return 1
# move default config to -doc package and use our own default config
@@ -141,9 +144,9 @@ unixodbc() {
_mv_mod_k db_unixodbc
}
-md5sums="a043944e195338d56bdfdcd6c86a468b kamailio-3.0.0_src_2010-01-12_6d1e9f.tar.gz
+md5sums="c0e488ab240f9a4668c10068e3fb2cae kamailio-3.0.1_src.tar.gz
eb665248ee39cf755a247286affc5cbb kamailio.cfg
81100c479890a2a8c2628db22fdd1a0c kamailio.initd
c646af2dd31f5c4289a2f802c873d98f kamailio.pre-install
3fbaf633ff1620d0d526fc4047c7bed9 kamailio.post-install
-10f8be110985a841dd5b892f86eb6722 kamailio-backslash.patch"
+36f81be3a082a81497e261ac8e6c5414 kamailio-3-backslash.patch"
diff --git a/testing/kamailio/kamailio-3-backslash.patch b/testing/kamailio/kamailio-3-backslash.patch
new file mode 100644
index 00000000..f132aeba
--- /dev/null
+++ b/testing/kamailio/kamailio-3-backslash.patch
@@ -0,0 +1,36 @@
+diff --git a/scripts/kamdbctl.base b/scripts/kamdbctl.base
+index 83f5a8a..5b640be 100644
+--- a/utils/kamctl/kamdbctl.base
++++ b/utils/kamctl/kamdbctl.base
+@@ -32,13 +32,13 @@ INSTALL_PRESENCE_TABLES=${INSTALL_PRESENCE_TABLES:-ask}
+
+ # Used by dbtext and db_berkeley to define tables to be created, used by
+ # postgres to do the grants
+-STANDARD_TABLES=${STANDARD_TABLES:-version acc dbaliases lcr domain grp
+- uri speed_dial gw pdt subscriber location re_grp trusted
+- address missed_calls usr_preferences aliases silo dialog
++STANDARD_TABLES=${STANDARD_TABLES:-version acc dbaliases lcr domain grp \
++ uri speed_dial gw pdt subscriber location re_grp trusted \
++ address missed_calls usr_preferences aliases silo dialog \
+ dispatcher dialplan}
+-EXTRA_TABLES=${EXTRA_TABLES:-imc_members imc_rooms cpl sip_trace domainpolicy carrierroute
++EXTRA_TABLES=${EXTRA_TABLES:-imc_members imc_rooms cpl sip_trace domainpolicy carrierroute \
+ carrier_name domain_name carrierfailureroute userblacklist globalblacklist htable purplemap}
+-PRESENCE_TABLES=${PRESENCE_TABLES:-presentity active_watchers watchers xcap
++PRESENCE_TABLES=${PRESENCE_TABLES:-presentity active_watchers watchers xcap \
+ pua rls_presentity rls_watchers}
+
+ # SQL definitions
+@@ -61,9 +61,9 @@ GREP=${GREP:-grep}
+ SED=${SED:-sed}
+
+ # define what modules should be installed
+-STANDARD_MODULES=${STANDARD_MODULES:-standard acc lcr domain group permissions
+- registrar usrloc msilo alias_db uri_db
+- speeddial avpops auth_db pdt dialog dispatcher
++STANDARD_MODULES=${STANDARD_MODULES:-standard acc lcr domain group permissions \
++ registrar usrloc msilo alias_db uri_db \
++ speeddial avpops auth_db pdt dialog dispatcher \
+ dialplan}
+ EXTRA_MODULES=${EXTRA_MODULES:-imc cpl siptrace domainpolicy carrierroute userblacklist htable purple}
+
diff --git a/testing/kamailio/kamailio-backslash.patch b/testing/kamailio/kamailio-backslash.patch
deleted file mode 100644
index c474db38..00000000
--- a/testing/kamailio/kamailio-backslash.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/utils/kamctl/kamdbctl.base Tue Dec 22 07:01:57 2009
-+++ b/utils/kamctl/kamdbctl.base Tue Dec 22 07:02:26 2009
-@@ -32,9 +32,9 @@
-
- # Used by dbtext and db_berkeley to define tables to be created, used by
- # postgres to do the grants
--STANDARD_TABLES=${STANDARD_TABLES:-version acc dbaliases lcr domain grp
-- uri speed_dial gw pdt subscriber location re_grp trusted
-- address missed_calls usr_preferences aliases silo dialog
-+STANDARD_TABLES=${STANDARD_TABLES:-version acc dbaliases lcr domain grp \
-+ uri speed_dial gw pdt subscriber location re_grp trusted \
-+ address missed_calls usr_preferences aliases silo dialog \
- dispatcher dialplan}
- EXTRA_TABLES=${EXTRA_TABLES:-imc_members imc_rooms cpl sip_trace domainpolicy carrierroute
- carrier_name domain_name carrierfailureroute userblacklist globalblacklist htable purplemap}