summaryrefslogtreecommitdiffstats
path: root/testing/osmo/osmo-0.2.10-build-mo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/osmo/osmo-0.2.10-build-mo.patch')
-rw-r--r--testing/osmo/osmo-0.2.10-build-mo.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/osmo/osmo-0.2.10-build-mo.patch b/testing/osmo/osmo-0.2.10-build-mo.patch
new file mode 100644
index 00000000..ac1b9aa2
--- /dev/null
+++ b/testing/osmo/osmo-0.2.10-build-mo.patch
@@ -0,0 +1,20 @@
+diff --git a/po/Makefile.am b/po/Makefile.am
+index b3c904a..f0ee467 100644
+--- a/po/Makefile.am
++++ b/po/Makefile.am
+@@ -16,8 +16,8 @@ all: $(MOFILES)
+
+ update-po: $(DOMAIN).pot $(POFILES) $(MOFILES)
+
+-%.mo: skip
+- @po=$(@:.mo=.po); if test $$po -nt $@ ; then $(MSGFMT) -c --statistics $$po -o $@; echo "$@ updated."; fi
++%.mo: %.po
++ @$(MSGFMT) -c --statistics $^ -o $@; echo "$@ updated."
+
+ %.po: $(DOMAIN).pot
+ $(MSGMERGE) $@ $< -o $@.in && mv $@.in $@
+@@ -41,4 +41,3 @@ uninstall-local:
+ clean-local:
+ rm -rf *.mo
+
+-skip: