summaryrefslogtreecommitdiffstats
path: root/testing/perl-test-exception/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-test-exception/APKBUILD')
-rw-r--r--testing/perl-test-exception/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/perl-test-exception/APKBUILD b/testing/perl-test-exception/APKBUILD
new file mode 100644
index 00000000..7b276c63
--- /dev/null
+++ b/testing/perl-test-exception/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=perl-test-exception
+_realname=Test-Exception
+pkgver=0.29
+pkgrel=0
+pkgdesc="Perl - Test exception based code"
+url="http://search.cpan.org/~adie/$_realname-$pkgver/"
+license="Artistic GPL"
+depends="perl perl-sub-uplevel"
+makedepends="perl-dev"
+#subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="9aea475db531d4fd4ce40cf25a0acd14 Test-Exception-0.29.tar.gz"