summaryrefslogtreecommitdiffstats
path: root/testing/py-buildutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-buildutils/APKBUILD')
-rw-r--r--testing/py-buildutils/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/py-buildutils/APKBUILD b/testing/py-buildutils/APKBUILD
new file mode 100644
index 00000000..f414f35e
--- /dev/null
+++ b/testing/py-buildutils/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Andrew Manison <amanison@anselsystems.com>
+# Maintainer:
+pkgname=py-buildutils
+_pkgname=${pkgname#py-}
+pkgver=0.3
+pkgrel=0
+pkgdesc="buildutils is a collection of enhancements to the Python distutils"
+url="http://pypi.python.org/pypi/buildutils/0.3"
+license="GPL"
+depends="python py-setuptools"
+makedepends="python-dev"
+install=
+subpackages=""
+source="http://pypi.python.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
+ python setup.py install --root="$pkgdir"
+ echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > "$pkgdir"/usr/lib/python2.6/site-packages/$_pkgname.pth
+}
+
+md5sums="fec620dee05f591edad386366b52e17b buildutils-0.3.tar.gz"