summaryrefslogtreecommitdiffstats
path: root/testing/pycrypto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pycrypto/APKBUILD')
-rw-r--r--testing/pycrypto/APKBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/testing/pycrypto/APKBUILD b/testing/pycrypto/APKBUILD
new file mode 100644
index 00000000..1ed827ca
--- /dev/null
+++ b/testing/pycrypto/APKBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pycrypto
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="A collection of cryptographic algorithms and protocols, implemented for use from Python."
+url="http://www.amk.ca/python/code/crypto.html"
+license="GPL"
+depends="python"
+makedepends="gmp-dev python-dev"
+source="http://www.amk.ca/files/python/crypto/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ python setup.py build install --root="$pkgdir"
+}
+md5sums="4d5674f3898a573691ffb335e8d749cd pycrypto-2.0.1.tar.gz"