summaryrefslogtreecommitdiffstats
path: root/testing/sems/0001-makefile-fail-on-errors.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/sems/0001-makefile-fail-on-errors.patch')
-rw-r--r--testing/sems/0001-makefile-fail-on-errors.patch170
1 files changed, 170 insertions, 0 deletions
diff --git a/testing/sems/0001-makefile-fail-on-errors.patch b/testing/sems/0001-makefile-fail-on-errors.patch
new file mode 100644
index 00000000..9dcbb230
--- /dev/null
+++ b/testing/sems/0001-makefile-fail-on-errors.patch
@@ -0,0 +1,170 @@
+From 7773c850b91d5c78679606065402caac29219dd8 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 18 Dec 2009 08:57:27 +0000
+Subject: [PATCH 1/2] makefile fail on errors
+
+---
+ Makefile | 8 ++++----
+ apps/Makefile | 12 ++++++------
+ core/Makefile | 2 +-
+ core/plug-in/Makefile | 14 +++++++-------
+ core/plug-in/Makefile.app_module | 4 ++--
+ 5 files changed, 20 insertions(+), 20 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 7dd01de..c210761 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,21 +28,21 @@ clean:
+
+ .PHONY: modules
+ modules:
+- -@for r in $(modules) "" ; do \
++ @for r in $(modules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- $(MAKE) -C $$r all; \
++ $(MAKE) -C $$r all || exit 1; \
+ fi ; \
+ done
+
+ .PHONY: install
+ install:
+- -@for r in $(imodules) "" ; do \
++ @for r in $(imodules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- $(MAKE) -C $$r install; \
++ $(MAKE) -C $$r install || exit 1; \
+ fi ; \
+ done
+ -@if [ -d ser-0.9.6-sems ]; then \
+diff --git a/apps/Makefile b/apps/Makefile
+index 23c6437..57df618 100644
+--- a/apps/Makefile
++++ b/apps/Makefile
+@@ -30,11 +30,11 @@ clean:
+
+ .PHONY: modules
+ modules:
+- -@for r in $(modules) "" ; do \
++ @for r in $(modules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- COREPATH=../$(COREPATH) $(MAKE) -C $$r all; \
++ COREPATH=../$(COREPATH) $(MAKE) -C $$r all || exit 1; \
+ fi ; \
+ done
+
+@@ -43,20 +43,20 @@ install: install-bin install-cfg
+
+ .PHONY: install-bin
+ install-bin:
+- -@for r in $(modules) "" ; do \
++ @for r in $(modules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- COREPATH=../$(COREPATH) $(MAKE) -C $$r install; \
++ COREPATH=../$(COREPATH) $(MAKE) -C $$r install || exit 1; \
+ fi ; \
+ done
+
+ .PHONY: install-cfg
+ install-cfg: $(DESTDIR)$(cfg-target)
+- -@for r in $(modules) "" ; do \
++ @for r in $(modules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg; \
++ COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg || exit 1; \
+ fi ; \
+ done
+diff --git a/core/Makefile b/core/Makefile
+index e3734d5..e1fe274 100644
+--- a/core/Makefile
++++ b/core/Makefile
+@@ -11,7 +11,7 @@ AUDIO_FILES=$(notdir $(wildcard wav/*.wav))
+
+ .PHONY: all
+ all: ../Makefile.defs
+- -@$(MAKE) deps && \
++ @$(MAKE) deps && \
+ $(MAKE) $(NAME) && \
+ $(MAKE) modules
+
+diff --git a/core/plug-in/Makefile b/core/plug-in/Makefile
+index e7d988c..cc38e2f 100644
+--- a/core/plug-in/Makefile
++++ b/core/plug-in/Makefile
+@@ -1,6 +1,6 @@
+ include ../../Makefile.defs
+
+-exclude_modules ?= g722
++exclude_modules ?= g722 speex
+ #echo
+
+ modules = $(filter-out $(subst ;, ,$(exclude_modules)) \
+@@ -25,30 +25,30 @@ clean:
+
+ .PHONY: modules
+ modules:
+- -@for r in $(modules) "" ; do \
++ @for r in $(modules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- $(MAKE) -C $$r all; \
++ $(MAKE) -C $$r all || exit 1; \
+ fi ; \
+ done
+
+ .PHONY: install
+ install:
+- -@for r in $(modules) "" ; do \
++ @for r in $(modules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- $(MAKE) -C $$r install; \
++ $(MAKE) -C $$r install || exit 1; \
+ fi ; \
+ done
+
+ .PHONY: install-cfg
+ install-cfg: $(DESTDIR)$(cfg-target)
+- -@for r in $(modules) "" ; do \
++ @for r in $(modules) "" ; do \
+ if [ -n "$$r" ]; then \
+ echo "" ; \
+ echo "" ; \
+- COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg; \
++ COREPATH=../$(COREPATH) $(MAKE) -C $$r install-cfg || exit 1; \
+ fi ; \
+ done
+diff --git a/core/plug-in/Makefile.app_module b/core/plug-in/Makefile.app_module
+index 8b7acaa..a6e1ef2 100644
+--- a/core/plug-in/Makefile.app_module
++++ b/core/plug-in/Makefile.app_module
+@@ -27,12 +27,12 @@ depends = $(srcs:.cpp=.d)
+
+ .PHONY: all
+ all: $(extra_target)
+- -@$(MAKE) deps && \
++ @$(MAKE) deps && \
+ $(MAKE) $(lib_full_name)
+
+ .PHONY: module_package
+ module_package: $(extra_target)
+- -@$(MAKE) deps && \
++ @$(MAKE) deps && \
+ $(MAKE) $(lib_name)
+
+
+--
+1.6.5.6
+