summaryrefslogtreecommitdiffstats
path: root/testing/thunar-media-tags-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/thunar-media-tags-plugin/APKBUILD')
-rw-r--r--testing/thunar-media-tags-plugin/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/thunar-media-tags-plugin/APKBUILD b/testing/thunar-media-tags-plugin/APKBUILD
new file mode 100644
index 00000000..cbcb46ac
--- /dev/null
+++ b/testing/thunar-media-tags-plugin/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=thunar-media-tags-plugin
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="Media tags plugin for Thunar file manager"
+url="http://thunar.xfce.org/pwiki/projects/thunar-media-tags-plugin"
+license="GPL"
+depends=
+makedepends="thunar-dev taglib-dev"
+install=
+subpackages=
+source="http://mocha.xfce.org/archive/src/thunar-plugins/thunar-media-tags-plugin/${pkgver%.*}/thunar-media-tags-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir"/usr/lib/*/*.la
+}
+
+md5sums="8a95f0ea4df6f757c1c94eb5442d2ff5 thunar-media-tags-plugin-0.1.2.tar.bz2"