summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-nixio/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/lua-nixio/APKBUILD b/testing/lua-nixio/APKBUILD
new file mode 100644
index 00000000..6e84e8c1
--- /dev/null
+++ b/testing/lua-nixio/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-nixio
+_name=nixio
+pkgver=0.3
+pkgrel=0
+pkgdesc="General POSIX IO library for Lua"
+url="http://dev.luci.freifunk-halle.net/nixio/doc/"
+license="Apache"
+makedepends="lua-dev openssl-dev"
+depends="lua"
+source="http://dev.luci.freifunk-halle.net/nixio/nixio-0.3.tar.bz2"
+
+_builddir="$srcdir"/$_name-$pkgver
+build() {
+ cd "$_builddir"
+ make LUA_MODULEDIR="$pkgdir"/usr/share/lua/5.1 \
+ LUA_LIBRARYDIR="$pkgdir"/usr/lib/lua/5.1 \
+ CFLAGS="$CFLAGS"
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/share/lua/5.1 \
+ "$pkgdir"/usr/lib/lua/5.1
+ # The makefiles put the LDFLAGS to early, we trick them to the end
+ # by override LINK and NIXIO_LDFLAGS_POST
+ make LUA_MODULEDIR="$pkgdir"/usr/share/lua/5.1 \
+ LUA_LIBRARYDIR="$pkgdir"/usr/lib/lua/5.1 \
+ LINK="$CC" \
+ NIXIO_LDFLAGS_POST="-lcrypto $LDFLAGS" \
+ install
+}
+
+md5sums="7fa6a989cd2644347d969cb6e3a5c186 nixio-0.3.tar.bz2"