summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
Diffstat (limited to 'unstable')
-rw-r--r--unstable/gnump3d/APKBUILD29
-rw-r--r--unstable/gnump3d/gnump3d.confd6
-rw-r--r--unstable/gnump3d/gnump3d.initd37
-rw-r--r--unstable/liblockfile/APKBUILD32
-rw-r--r--unstable/mailx-support/APKBUILD17
-rw-r--r--unstable/mailx-support/mailx-support-ldflags.patch15
6 files changed, 130 insertions, 6 deletions
diff --git a/unstable/gnump3d/APKBUILD b/unstable/gnump3d/APKBUILD
new file mode 100644
index 00000000..b3674329
--- /dev/null
+++ b/unstable/gnump3d/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=gnump3d
+pkgver=3.0
+pkgrel=0
+pkgdesc="A streaming server for MP3, OGG vorbis and other streamable files"
+url="http://www.gnump3d.org/"
+license="GPL-2"
+depends="perl"
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="http://savannah.gnu.org/download/gnump3d/$pkgname-$pkgver.tar.gz
+ gnump3d.confd
+ gnump3d.initd"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make PREFIX="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+ mv "$pkgdir"/usr/local "$pkgdir"-doc/
+}
+
+md5sums="d2b665c3267253cc8cae29659131b9b4 gnump3d-3.0.tar.gz
+59f0286d4c943226a67ab7b7787547c6 gnump3d.confd
+5202488dff1c7e6c6788fb00fb32f071 gnump3d.initd"
diff --git a/unstable/gnump3d/gnump3d.confd b/unstable/gnump3d/gnump3d.confd
new file mode 100644
index 00000000..1d6cf397
--- /dev/null
+++ b/unstable/gnump3d/gnump3d.confd
@@ -0,0 +1,6 @@
+# Set this to 0 to stop the init script from indexing your mp3s.
+# It takes the longest on the first time, but after that, it only does
+# updates.
+
+DO_INDEX=1
+
diff --git a/unstable/gnump3d/gnump3d.initd b/unstable/gnump3d/gnump3d.initd
new file mode 100644
index 00000000..43290ee3
--- /dev/null
+++ b/unstable/gnump3d/gnump3d.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/media-sound/gnump3d/files/gnump3d.init.d,v 1.4 2008/06/03 14:52:33 beandog Exp $
+
+opts="start stop index"
+
+depend() {
+ need net
+ after netmount nfsmount
+}
+
+start() {
+ ebegin "Starting gnump3d"
+
+ if [ ${DO_INDEX} -eq 1 ]; then
+ ebegin "Updating index of music files (may take a while for the first time)"
+ /usr/bin/gnump3d-index
+ eend $?
+ fi
+
+ start-stop-daemon --start --quiet --exec /usr/bin/gnump3d2 --make-pidfile \
+ --pidfile /var/run/gnump3d.pid --background -- --quiet
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gnump3d"
+ start-stop-daemon --stop --quiet --pidfile /var/run/gnump3d.pid
+ eend $?
+}
+
+index() {
+ ebegin "Indexing music files"
+ /usr/bin/gnump3d-index
+ eend $?
+}
diff --git a/unstable/liblockfile/APKBUILD b/unstable/liblockfile/APKBUILD
new file mode 100644
index 00000000..8d89af84
--- /dev/null
+++ b/unstable/liblockfile/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=liblockfile
+pkgver=1.08
+pkgrel=0
+pkgdesc="Implements functions designed to lock the standard mailboxes"
+url="http://www.debian.org"
+license="GPL"
+depends=""
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="ftp://ftp.debian.org/debian/pool/main/libl/$pkgname/"$pkgname"_"$pkgver".orig.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ install -m2755 -D "$srcdir"/"$pkgname-$pkgver"/dotlockfile "$pkgdir"/usr/bin/dotlockfile
+ install -m644 -D "$srcdir"/"$pkgname-$pkgver"/lockfile.h "$pkgdir"/usr/include/lockfile.h
+ install -m644 -D "$srcdir"/"$pkgname-$pkgver"/maillock.h "$pkgdir"/usr/include/maillock.h
+ install -m644 -D "$srcdir"/"$pkgname-$pkgver"/liblockfile.a "$pkgdir"/usr/lib/liblockfile.a
+ install -m644 -D "$srcdir"/"$pkgname-$pkgver"/dotlockfile.1 "$pkgdir"-doc/usr/man/man1/dotlockfile.1
+ install -m644 -D "$srcdir"/"$pkgname-$pkgver"/lockfile_create.3 "$pkgdir"-doc/usr/man/man3/lockfile_create.3
+ install -m644 -D "$srcdir"/"$pkgname-$pkgver"/maillock.3 "$pkgdir"-doc/usr/man/man3/maillock.3
+}
+
+md5sums="c24e2dfb4a2aab0263fe5ac1564d305e liblockfile_1.08.orig.tar.gz"
diff --git a/unstable/mailx-support/APKBUILD b/unstable/mailx-support/APKBUILD
index 2a8fe731..503f2030 100644
--- a/unstable/mailx-support/APKBUILD
+++ b/unstable/mailx-support/APKBUILD
@@ -5,20 +5,25 @@ pkgver=20060102
pkgrel=0
pkgdesc="Provides lockspool utility"
url="http://www.openbsd.org"
-license="GPL"
+license="BSD"
depends=""
makedepends=""
install=
subpackages="$pkgname-doc"
-source="http://gentoo.osuosl.org/distfiles/$pkgname-$pkgver.tar.bz2"
+source="http://gentoo.osuosl.org/distfiles/$pkgname-$pkgver.tar.bz2
+ mailx-support-ldflags.patch"
build() {
cd "$srcdir"/$pkgname-$pkgver
-#need to add a DESTDIR in make file
+ for i in ../*.patch; do
+ msg "Appling $i..."
+ patch -p1 < $i || return 1
+ done
make || return 1
- make DESTDIR="$pkgdir" install
-
+ install -m755 -D "$srcdir"/"$pkgname-$pkgver"/lockspool "$pkgdir"/usr/libexec/lockspool
+ install -m644 -D "$srcdir"/"$pkgname-$pkgver"/lockspool.1 "$pkgdir"-doc/usr/share/man/man1/lockspool.1
}
-md5sums="3f671fe4368a5b536e8384980a9a5c80 mailx-support-20060102.tar.bz2"
+md5sums="3f671fe4368a5b536e8384980a9a5c80 mailx-support-20060102.tar.bz2
+32a98aee973db8860f1f53a9297b8dd9 mailx-support-ldflags.patch"
diff --git a/unstable/mailx-support/mailx-support-ldflags.patch b/unstable/mailx-support/mailx-support-ldflags.patch
new file mode 100644
index 00000000..97c5b600
--- /dev/null
+++ b/unstable/mailx-support/mailx-support-ldflags.patch
@@ -0,0 +1,15 @@
+--- mailx-support-20060102.orig/Makefile
++++ mailx-support-20060102/Makefile
+@@ -17,10 +17,10 @@ clean:
+ ${RM} -f ${PRODUCTS} *.o
+
+ mail.local: mail.local.o locking.o open_with_exlock.o
+- ${CC} ${CFLAGS} -o $@ $^
++ ${CC} ${LDFLAGS} ${CFLAGS} -o $@ $^
+
+ lockspool: lockspool.o locking.o open_with_exlock.o
+- ${CC} ${CFLAGS} -o $@ $^
++ ${CC} ${LDFLAGS} ${BINDNOW_FLAGS} ${CFLAGS} -o $@ $^
+
+ .c.o:
+ ${CC} ${CFLAGS} -c -o $@ $^