summaryrefslogtreecommitdiffstats
path: root/x11/font-adobe-utopia-75dpi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'x11/font-adobe-utopia-75dpi/APKBUILD')
-rw-r--r--x11/font-adobe-utopia-75dpi/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/font-adobe-utopia-75dpi/APKBUILD b/x11/font-adobe-utopia-75dpi/APKBUILD
new file mode 100644
index 00000000..48f1df48
--- /dev/null
+++ b/x11/font-adobe-utopia-75dpi/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=font-adobe-utopia-75dpi
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="X.org adobe 75dpi font"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends="encodings font-alias mkfontscale mkfontdir fontconfig"
+makedepends="pkgconfig font-util-dev bdftopcf"
+install="$pkgname.post-install $pkgname.post-upgrade"
+source="http://xorg.freedesktop.org/releases/individual/font/$pkgname-$pkgver.tar.bz2
+ $install"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --with-mapfiles=/usr/share/fonts/util \
+ --with-fontdir=/usr/share/fonts/75dpi
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="dd912284e4750023f9682812532fa033 font-adobe-utopia-75dpi-1.0.1.tar.bz2
+a24308692d7112b79a5a188c0b5c2e41 font-adobe-utopia-75dpi.post-install
+a24308692d7112b79a5a188c0b5c2e41 font-adobe-utopia-75dpi.post-upgrade"