summaryrefslogtreecommitdiffstats
path: root/x11/inputproto
diff options
context:
space:
mode:
Diffstat (limited to 'x11/inputproto')
-rw-r--r--x11/inputproto/APKBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/x11/inputproto/APKBUILD b/x11/inputproto/APKBUILD
new file mode 100644
index 00000000..c0e81068
--- /dev/null
+++ b/x11/inputproto/APKBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=inputproto
+pkgver=1.5.0
+pkgrel=0
+pkgdesc="X11 Input extension wire protocol"
+url="http://xorg.freedesktop.org/"
+license="custom"
+source="http://xorg.freedesktop.org/releases/individual/proto/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="dcc36554aea1338b3813943daf1e9988 inputproto-1.5.0.tar.bz2"