summaryrefslogtreecommitdiffstats
path: root/x11/wine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'x11/wine/APKBUILD')
-rw-r--r--x11/wine/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11/wine/APKBUILD b/x11/wine/APKBUILD
new file mode 100644
index 00000000..aae298c8
--- /dev/null
+++ b/x11/wine/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wine
+pkgver=1.1.29
+pkgrel=0
+pkgdesc="A compatibility layer for running Windows programs"
+url="http://www.winehq.com"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
+ libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison"
+# lcms
+source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
+ 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
+ ./configure --prefix=/usr --sysconfdir=/etc --with-x
+ make depend || return 1
+ make || return 1
+ make prefix="$pkgdir"/usr install || return 1
+ mkdir -p "$pkgdir"/etc/wine
+}
+md5sums="c3a9218840a80b29932cee49f2d45d9d wine-1.1.29.tar.bz2
+63c4a6aee199039d35e6b57fa505e887 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"