summaryrefslogtreecommitdiffstats
path: root/x11/xfce4-battery-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xfce4-battery-plugin/APKBUILD')
-rw-r--r--x11/xfce4-battery-plugin/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11/xfce4-battery-plugin/APKBUILD b/x11/xfce4-battery-plugin/APKBUILD
new file mode 100644
index 00000000..d67d1715
--- /dev/null
+++ b/x11/xfce4-battery-plugin/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-battery-plugin
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="A battery monitor plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+license="GPL-2"
+makedepends="xfce4-panel-dev libxfcegui4-dev perl-xml-parser intltool"
+install="$pkname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2
+ compile_x86_64.diff"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/compile_x86_64.diff || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="d8a666d85bb3c1dd007b547de4dd7037 xfce4-battery-plugin-0.5.1.tar.bz2
+d9a927bca032e9b10a04046c154243a1 compile_x86_64.diff"