summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/xkbcomp/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/xkbcomp/APKBUILD b/x11/xkbcomp/APKBUILD
new file mode 100644
index 00000000..4658d45b
--- /dev/null
+++ b/x11/xkbcomp/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xkbcomp
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="compile XKB keyboard description"
+url="http://xorg.freedesktop.org"
+license="custom"
+depends="uclibc libX11 libxkbfile"
+makedepends="pkgconfig libX11-dev libxkbfile-dev"
+subpackages="$pkgname-doc"
+source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="6cc96c3e4ed5d9802fe717beac008f19 xkbcomp-1.0.5.tar.bz2"