summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/xsetmode/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11/xsetmode/APKBUILD b/x11/xsetmode/APKBUILD
new file mode 100644
index 00000000..393b024b
--- /dev/null
+++ b/x11/xsetmode/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xsetmode
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="set the mode for an X Input device"
+url="http://xorg.freedesktop.org/"
+license="custom"
+subpackages="$pkgname-doc"
+depends="libxi libx11 uclibc"
+makedepends="pkgconfig libxi-dev libx11-dev"
+source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="d074e79d380b031d2f60e4cd56538c93 xsetmode-1.0.0.tar.bz2"