summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/swfdec-mozilla/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11/swfdec-mozilla/APKBUILD b/x11/swfdec-mozilla/APKBUILD
new file mode 100644
index 00000000..b2409e8d
--- /dev/null
+++ b/x11/swfdec-mozilla/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=swfdec-mozilla
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="free plugin for Mozilla browsers that uses the Swfdec library for playing SWF files"
+url="http://swfdec.freedesktop.org"
+license="LGPL"
+makedepends="swfdec-dev"
+depends=
+source="http://swfdec.freedesktop.org/download/$pkgname/0.8/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static \
+ --with-plugin-dir=/usr/lib/mozilla/plugins/
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="716632e0d35b3c1582c180569ba30346 swfdec-mozilla-0.8.2.tar.gz"